Archicad 27 C++ API
Loading...
Searching...
No Matches
API_VertType Struct Reference

Representation of a 3D vertex. More...

#include <APIdefs_3D.h>

Public Attributes

API_3D_Head head
 Header information of this component. This specifies the type and database index.
 
double x
 The x coordinate of the point in the model space.
 
double y
 The y coordinate of the point in the model space.
 
double z
 The z coordinate of the point in the model space.
 

Detailed Description

Representation of a 3D vertex.

Remarks
A node in the x-y-z space, defined by its 3 coordinates. The vertices are the endpoints of the edges. In the API_EdgeType structure the vert1, vert2 fields refers to an API_VertType component by index. With these indices can be used to retrieve the given vertices from the database. Accessing vertices are based on a body. First you must get a body by ACAPI_ModelAccess_GetComponent and just after is obtainable its components.