Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ZoneCatType Struct Reference

Zone category attribute representation. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Contains the name and the index of the zone category attribute.
 
GS::uchar_t catCode [API_UniLongNameLen]
 Contains the code for the zone category attribute.
 
GS::uchar_t stampName [API_UniLongNameLen]
 Contains the name of the zone stamp library part for the zone category attribute.
 
API_Guid stampMainGuid
 The main part of the unique identifier of the zone stamp library part.
 
API_Guid stampRevGuid
 The revision part of the unique identifier of the zone stamp library part.
 
API_RGBColor rgb
 The RGB components of the zone color.
 

Detailed Description

Zone category attribute representation.

Remarks
This attribute exists in Archicad only. One zone category always exists, i.e. you cannot delete the last zone category attribute. There are additional data assigned to zone category attributes in the API_AttributeDef structure; the current values of the parameters are passed through the zone_addParItems field. Refer to the API_AddParType structure to get more details on it.