Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::ElementDefault Class Reference

A base class for all element defaults. More...

#include <ElementDefault.hpp>

Inheritance diagram for ACAPI::v1::ElementDefault:
ACAPI::v1::Object ACAPI::MEP::v1::ElementDefault ACAPI::MEP::v1::RoutingElementDefault ACAPI::MEP::v1::RoutingNodeDefault ACAPI::MEP::v1::RoutingSegmentDefault ACAPI::MEP::v1::AccessoryDefault ACAPI::MEP::v1::BendDefault ACAPI::MEP::v1::BranchDefault ACAPI::MEP::v1::EquipmentDefault ACAPI::MEP::v1::FittingDefault ACAPI::MEP::v1::FlexibleSegmentDefault ACAPI::MEP::v1::RigidSegmentDefault ACAPI::MEP::v1::TakeOffDefault ACAPI::MEP::v1::TerminalDefault ACAPI::MEP::v1::TransitionDefault

Public Member Functions

Result< void > SetAsArchicadDefault () const
 Sets the locally prepared Default settings to the Archicad Default.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Protected Member Functions

 ElementDefault (std::shared_ptr< Impl::ElementDefaultImpl > impl)
 Constructs a new ElementDefault.
 
- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 

Additional Inherited Members

- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

A base class for all element defaults.

This class represents the default state of Archicad elements. When an element is placed in Archicad, either from the API of from the UI, it always uses the Element Defaults as its default parameters.

Constructor & Destructor Documentation

◆ ElementDefault()

ACAPI::v1::ElementDefault::ElementDefault ( std::shared_ptr< Impl::ElementDefaultImpl >  impl)
protected

Constructs a new ElementDefault.

Parameters
implImpl instance of the element default.

Member Function Documentation

◆ SetAsArchicadDefault()

Result< void > ACAPI::v1::ElementDefault::SetAsArchicadDefault ( ) const

Sets the locally prepared Default settings to the Archicad Default.

Returns
Error if Archicad could not apply the set of values to the Default.