Archicad 28 C++ API
|
Describes a Structural Analytical Model Analytical Link Geometry. More...
#include <APIdefs_AnalyticalElements.h>
Public Attributes | |
GS::Array< API_Coord3D > | coordinates |
Positions of the analytical link. | |
GS::Array< API_AnalyticalCurve > | curves |
Describes the joining ends of a 2D link (if they are not connected to a vertex) | |
API_Vector3D | translationStiffnessVector |
Link's translation stiffness vector in the start member's coordinate system. | |
API_Vector3D | rotationStiffnessVector |
Link's rotation stiffness vector in the start member's coordinate system. | |
Describes a Structural Analytical Model Analytical Link Geometry.