Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalSurfaceMember Struct Reference

Describes a Structural Analytical Model Surface Member. More...

#include <APIdefs_AnalyticalModel.h>

Public Attributes

API_AnalyticalMemberType analyticalMemberType
 The type of the represented element.
 
API_Guid elemGuid
 The unique identifier of the represented element.
 
API_AnalyticalSurface surface
 The type of the surface.
 
GS::Array< API_AnalyticalCurvecontour
 The contour as a list of Structural Analytical Model Curves.
 
GS::Array< GS::Array< API_AnalyticalCurve > > holeContours
 The list of eventual holes as a list of hole contours.
 
GS::Array< API_AnalyticalNodeinternalNodes
 List of eventual Internal Nodes set on this Structural Analytical Model Curve Member.
 
double thickness
 The structure thickness.
 
API_Vector3D lcsXVector
 The X axis of the local coordinate system.
 
double ez
 The structure eccentricity.
 
API_Vector3D ezVector
 The structure eccentricity vector.
 
API_AttributeIndex materialAttrIndex
 The material attribute index that references the material in the system.
 
API_AttributeIndex layerAttrIndex
 The containing layer's attribute index.
 
API_Analytical2DFEMType FEMType
 The FEM type of the surface member.
 
API_Guid groupId
 The unique identifier of the group containing the element.
 

Detailed Description

Describes a Structural Analytical Model Surface Member.

Since
Archicad 25