Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AngleDimensionType Struct Reference

Represents an angle dimension. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
short linPen
 Pen attribute index of dimension and witness lines.
 
bool smallArc
 Show the smaller arc of a-b (inner or outer dimension).
 
bool onlyDimensionText
 Only dimension texts (notes) are visible — no leader line.
 
API_TextPosID textPos
 up/in/below
 
API_DirID textWay
 The position of the text relative to the dimension line (see API_DirID). The possible values are: APIDir_Parallel, APIDir_Horizontal, APIDir_Perpendicular.
 
API_WitnessID witnessForm
 Witness line format (see API_WitnessID).
 
double witnessVal
 Gap (APIWtn_Fix) or length (APIWtn_Large) of witness line according to witnessForm.
 
API_MarkerData markerData
 Marker specification (see API_MarkerData).
 
API_NoteType note
 Parameters of the dimension text.
 
API_DimBase base [4]
 Reference points.
 
API_Coord pos
 Point to fit dimension arc.
 
API_Coord origo
 Of dimension arc.
 
double dimVal
 Angle of dimensioned items [radian].
 
double radius
 Of dimension arc.
 

Detailed Description

Represents an angle dimension.