Archicad 27 C++ API
Loading...
Searching...
No Matches
API_BeamSegmentType Struct Reference

Represents an segment of the beam element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 The guid of the owner beam.
 
API_AssemblySegmentData assemblySegmentData
 General informations about segment.
 
API_OverriddenAttribute leftMaterial
 The material override structure of the left side of the beam.
 
API_OverriddenAttribute topMaterial
 Material override structure of the top of the beam.
 
API_OverriddenAttribute rightMaterial
 Material override structure of the right side of the beam.
 
API_OverriddenAttribute bottomMaterial
 Material override structure of the bottom of the beam.
 
API_OverriddenAttribute endsMaterial
 The material override structure of the beginning and end side of the beam.
 
bool materialsChained
 Are surface materials chained?
 

Detailed Description

Represents an segment of the beam element.