Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CompositeQuantity Struct Reference

Describes the different calculated values for skins of composite or complex elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_CompositeId compositeId
 Identifies the composite skin and sub-element.
 
double volumes
 Volumes of consecutive skins of composite or complex elements (in the order defined by the fill indexes).
 
double projectedArea
 The projected area of consecutive skins of composite or complex elements (in the order defined by the fill indexes). Its value is 0 if the Use Legacy intersection and Surface methods for model elements is turned on in the Project Preferences, because the special 3D model used to calculate this information cannot be created in legacz mode.
 
API_AttributeIndex buildMatIndices
 Building materials of consecutive skins of composite or complex elements.
 
short flags
 The flags of consecutive skins of composite or complex elements (in the order defined by the fill indexes). See the flagBits in API_CWallComponent.
 

Detailed Description

Describes the different calculated values for skins of composite or complex elements.