Archicad 27 C++ API
Loading...
Searching...
No Matches
API_CutPlaneType Struct Reference

Represents a section element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_CutPlaneShowType cutPlShow
 Stories to show cutplane on:
 
short storyToShowOn
 Story to show cutplane on, if cutPlShow is APICutPl_ShowOnOneStory.
 
API_SectionSegment segment
 Section segment.
 
API_CutPlaneMarkerShowType markerShow
 Show side markers or middle marker.
 
API_MarkerLinkDataType linkData
 Link information for segments, elevations, details and worksheets.
 

Detailed Description

Represents a section element.

Remarks
Most of the original structure members are now in API_SectionSegment. See also API_ElevationType.

Member Data Documentation

◆ cutPlShow

API_CutPlaneType::cutPlShow

Stories to show cutplane on:

API_CutPlaneShowType Meaning
APICutPl_ShowAll Show on All stories
APICutPl_ShowOnOneStory Show only on one story, setting in storyToShowOn
APICutPl_ShowInRange Show on stories which are in the range
APICutPl_ShowPartRange Show on stories which are in or cut by the range