Archicad 27 C++ API
Loading...
Searching...
No Matches
API_EditPars Struct Reference

Transformation parameters for elements. More...

#include <APIdefs_Elements.h>

Public Attributes

API_EditCmdID typeID
 the operation code
 
bool withDelete
 delete the target element after the operation (drag or drag a copy)
 
bool topNodeStretched
 the upper node must be edited in case of vertical stretching
 
API_Coord origC
 the origo; used for mirror and rotate
 
API_Coord3D begC
 the start point of the edit vector; this is the reference point
 
API_Coord3D endC
 the end point of the edit vector; generally this is the second click in Archicad
 
API_Coord3D endC2
 additional vector end point; used for mirror
 

Detailed Description

Transformation parameters for elements.

Remarks
Generally you have to think about the coordinates in the same way you should click in Archicad to perform the same operation. For example in case of rotation you have to set the origC field to the origo, the begC and endC fields to the start and end points of the rotation angle. The origo does not have vertical information, it just specifies the center of rotation. Other coordinates have a z component; its difference will specify the elevation factor; additive to the original operation. This structure is used by the ACAPI_Element_Edit function.