Archicad 28 C++ API
Loading...
Searching...
No Matches
API_Favorite Struct Reference

A container for Favorite entry settings. More...

#include <APIdefs_Favorite.h>

Public Member Functions

 API_Favorite (const GS::UniString &name=GS::EmptyUniString)
 Construct a new API_Favorite object with the given name and zeroed-out element.
 

Public Attributes

GS::UniString name
 Unique name identifier of the Favorite.
 
API_Element element
 The element settings of the Favorite.
 
GS::Optional< API_ElementMemomemo
 (Optional) The element memo settings of the Favorite.
 
GS::Optional< API_ElementelementMarker
 (Optional) The marker element settings of the Favorite.
 
GS::Optional< API_ElementMemomemoMarker
 (Optional) The marker element's memo settings of the Favorite.
 
GS::Optional< GS::Array< API_Property > > properties
 (Optional) The properties of the Favorite.
 
GS::Optional< GS::Array< GS::Pair< API_Guid, API_Guid > > > classifications
 (Optional) The classification system and classification item pairs of the Favorite.
 
GS::Optional< GS::Array< API_ElemCategoryValue > > elemCategoryValues
 (Optional) The element categories of the Favorite.
 
GS::Optional< API_FavoriteFolderHierarchy > folder
 (Optional) The folder of the Favorite.
 
GS::Optional< GS::Array< API_SubElement > > subElements
 (Optional) The subelements of the Favorite (
 

Detailed Description

A container for Favorite entry settings.

Since
Archicad 25
Remarks
In case of ACAPI_Favorite_Get and ACAPI_Favorite_Change functions, you have to set the name field for identifying the Favorite and set which optional fields do you want to retrieve/change. Remember to call ACAPI_DisposeElemMemoHdls for the memo and memoMarker fields if you set them and they are not needed anymore. The API_FavoriteFolderHierarchy type is a typedef of GS::Array <GS::UniString>;. In Archicad 25 the subElements member was introduced.

Constructor & Destructor Documentation

◆ API_Favorite()

API_Favorite::API_Favorite ( const GS::UniString &  name = GS::EmptyUniString)
inline

Construct a new API_Favorite object with the given name and zeroed-out element.

Parameters
nameName of the favorite.