Archicad 27 C++ API
Loading...
Searching...
No Matches
API_GridMesh Struct Reference

Describes a Curtain Wall segment geometry. More...

#include <APIdefs_Base.h>

Public Attributes

bool useIDs
 For internal use.
 
API_GridElemID lowerLeftPolyID
 The identifier of the left lower grid mesh polygon.
 
API_GridElemID lowerRightPolyID
 The identifier of the right lower grid mesh polygon.
 
GS::Array< API_GridMeshLinemeshLinesMainAxis
 Array of Grid Lines belong to the main axis (vertical).
 
GS::Array< API_GridMeshLinemeshLinesSecondaryAxis
 Array of Grid Lines belong to the secondary axis (horizontal).
 
GS::HashTable< API_GridElemID, API_GridMeshVertexmeshVertices
 Table of grid mesh vertices with identifier keys.
 
GS::HashTable< API_GridElemID, API_GridMeshPolygonmeshPolygons
 Table of grid mesh polygons with identifier keys.
 
GS::HashTable< API_GridElemID, API_GridMeshEdgemeshEdgesMainAxis
 Table of Grid Edges belong to the main axis (vertical).
 
GS::HashTable< API_GridElemID, API_GridMeshEdgemeshEdgesSecondaryAxis
 Table of Grid Edges belong to the secondary axis (horizontal).
 
API_GridElemID cornerPointIDs [4]
 the identifiers for the Lower left, lower right, upper right and upper left vertices of the grid mesh.
 

Detailed Description

Describes a Curtain Wall segment geometry.

Remarks