Archicad 28 C++ API
|
Represents a Hotlink Module type or XRef type hotlink instance element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
API_HotlinkTypeID | type |
Type of the hotlink. | |
API_Guid | hotlinkNodeGuid |
Reference to the associated hotlink node (see API_HotlinkNode). | |
API_Guid | hotlinkGroupGuid |
Reference to the associated element group. | |
API_Tranmat | transformation |
Placement transformation of the hotlink instance. | |
short | floorDifference |
Floor difference in case of hotlink module. | |
bool | suspendFixAngle |
Adjust angle of fixed-angle elements to reflect module rotation. | |
bool | skipNested |
Skip nested hotlinks. | |
bool | ignoreTopFloorLinks |
Top linked building elements will not keep their top floor links (homeFloorLinksOnly before 19). | |
bool | relinkWallOpenings |
Wall openings linked to stories will be relinked to walls to follow their elevation if the story structures differ. | |
bool | adjustLevelDiffs |
If this parameter is true, then all Hotlink elements will retain their original vertical position relative to the Hotlink insertion point. Otherwise elevation of elements will follow the shift in Story Levels in the Host Project. Therefore, Hotlink element may shift vertically. | |
Represents a Hotlink Module type or XRef type hotlink instance element.