Archicad 28 C++ API
|
Represents a level dimension. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
short | pen |
Pen attribute index of the dimension. | |
short | dimForm |
Format [0..9]: | |
bool | needPlus |
Show plus sign for positive numbers. | |
bool | staticLevel |
Static level dimension. | |
double | markerSize |
marker size in mms | |
double | angle |
Angle of the level dimension marker, in radians. | |
API_NoteType | note1 |
Parameters of the dimension text (see API_NoteType ). | |
API_NoteType | note2 |
Parameters of the secondary dimension text (see API_NoteType ); for dimForm = 8, 9. | |
API_Coord | loc |
Location of the marker. | |
double | level |
Level of the parent/floor, or static. | |
API_ElemType | parentType |
Refers to this element (see API_ElemType); refers to floor if API_ZombieElemID . | |
API_Guid | parentGuid |
Unique ID of referred element if parentType is not API_ZombieElemID . | |
API_DimOriginID | origin |
Origin of dimensioning (see API_DimOriginID ). | |
Represents a level dimension.
needFrame
member has been removed in v13; framing is now handled by the dimension note. The parentIndex
member has been removed in v18; use the parentGuid
field instead. From version 26 the type of the parentType
member was changed to API_ElemType. API_LevelDimensionType::dimForm |
Format [0..9]: