Archicad 28 C++ API
Loading...
Searching...
No Matches
API_Pen Struct Reference

Pen attribute representation. More...

#include <APIdefs_Environment.h>

Public Attributes

short index
 index of the pen. 1..255
 
UInt64 modiTime
 modification time of the pen.
 
API_RGBColor rgb
 Color of the pen.
 
double width
 Thickness of the pen defined in paper millimeters.
 
char description [128]
 Textual description of the pen; doesn't have to be unique, and can be empty.
 

Detailed Description

Pen attribute representation.

Remarks
This structure is used to manipulate pen attributes of the currently active Pen Table. Pens cannot be created or deleted; you can just modify them. There is no additional data assigned to pen attributes in the API_AttributeDef structure.

The index of Pen attributes normally must be between 1 and 255, but there are some special values:

Index Meaning
APIPen_Transparent (= 0) Transparent pen. Fill backgrounds having this pen index are drawn transparently.
APIPen_WindowBackground (= -1) Background pen. Fill backgrounds having this pen index are drawn with the current window background color.
1000 Grid color pen. Pen index for drawing the grid
1001 Zone fill color. This is the foreground color of a zone's fill; coming from the zone category; use the rgb value of the pen
1002 Ghost Story color. Pen index used for drawing ghost story elements
See also
API_Attr_Head,API_RGBColor, API_Attribute, Attribute Management Management