Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimArc Struct Reference

A primitive arc. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Prim_Head head
 General primitive element header.
 
API_AttributeIndex ltypeInd
 Line type attribute index.
 
bool solid
 Filled with solid color?
 
bool whole
 Whole arc?
 
short determination
 Line category:
 
bool reflected
 If true then the direction of the arc is negative (clockwise).
 
double penWeight
 Thickness of the arc [mm].
 
API_Coord orig
 Origin of the arc.
 
double r
 Radius of the arc.
 
double begAng
 Beginning angle of the arc (CCW, from the horizontal axis).
 
double endAng
 End angle of the arc (CCW, from the horizontal axis).
 
double angle
 0.0, or the angle of the 'a' axis.
 
double ratio
 1.0, or 'a/b' of the ellipse.
 

Detailed Description

A primitive arc.

Member Data Documentation

◆ determination

API_PrimArc::determination

Line category:

Category Meaning
APILine_DetOrigin Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.
APILine_DetInnerLine A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.
APILine_DetContourLine Lines in the Cut line category will be affected if you have chosen the 'Bold Cut Line' setting in the Line Weight menu of Display Options.