Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PrimPoly Struct Reference

A primitive polygon. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Prim_Head head
 General primitive element header.
 
API_AttributeIndex ltypeInd
 Line type attribute index.
 
bool solid
 Filled with solid color?
 
bool useRgb
 Have to use rgbColor when it set.
 
short determination
 Line category:
 
double penWeight
 Thickness of the polygon segments in mm.
 
Int32 nCoords
 Number of vertices.
 
Int32 nSubPolys
 Number of closed subpolygons including the first one.
 
Int32 nArcs
 Number of curves in the polygon.
 
API_ExtendedPenType fillPen
 (Overridden) pen attribute of the fill.
 
API_RGBColor rgbColor
 The color of fill if useRgb is set.
 

Detailed Description

A primitive polygon.

Remarks
The actual coordinates of the polyline vertices are passed in the par1 parameter of the ShapePrimsProc function. The par2 and par3 parameters contain the polygon endpoints and the polygon arcs, as in API_Polygon.

Member Data Documentation

◆ determination

API_PrimPoly::determination

Line category:

Category Meaning
APILine_DetOrigin Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.
APILine_DetInnerLine A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.
APILine_DetContourLine Lines in the Cut line category will be affected if you have chosen the 'Bold Cut Line' setting in the Line Weight menu of Display Options.