Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingBalusterSetType Struct Reference

Represents a Baluster Set element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 GUID of the Railing Pattern element owning this Baluster Set.
 
API_RailingFrameData frame
 Describes the boundaries of the Baluster Set.
 
API_RailingDistributionData distribution
 Describes the distribution of Balusters in the Baluster Set.
 
API_RailingBalusterType defBaluster
 The default Baluster element, from which the Baluster instances will be generated.
 
UInt32 nBalusters
 The amount of Balusters in the Baluster Set.
 

Detailed Description

Represents a Baluster Set element.