Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RailingType Struct Reference

Represents a Railing element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_LinkToSettings linkToSettings
 The mode of linking to home story.
 
API_RailingNodeType defNode
 The default Railing Node element, from which the Railing Node instances will be generated.
 
API_RailingSegmentType defSegment
 The default Railing Segment element, from which the Railing Segment instances will be generated.
 
API_StoryVisibility visibility
 The story visibility of the element. See API_StoryVisibility for details.
 
bool isAutoOnStoryVisibility
 Recalculate the story visibility automatically according to the actual elevation of the railing.
 
UInt32 nVertices
 The amount of vertices in the Railing's reference line.
 
short referenceLinePen
 The pen index of the Railing's reference line.
 
short contourPen
 The pen index of the Railing's contour line.
 
UInt32 nNodes
 The amount of Nodes in the Railing.
 
UInt32 nSegments
 The amount of Segments in the Railing.
 
double bottomOffset
 TBase height of the Railing relative to the floor level.
 

Detailed Description

Represents a Railing element.

Remarks
The Railing element is a complex structure of elements, requiring each subelement to be filled correctly.
Raling structure