Archicad 27 C++ API
Loading...
Searching...
No Matches
API_LinkToSettings Struct Reference

Option for linking model elements to their home stories. More...

#include <APIdefs_Elements.h>

Public Attributes

short homeStoryDifference
 Difference of home story from current story.
 
bool newCreationMode
 Use this structure during element creation. If it is true, then head.floorInd will not be taken into account, otherwise homeStoryDifference will be filled.
 

Detailed Description

Option for linking model elements to their home stories.

Remarks
Automatic link type can set only for API_BeamType, API_ColumnType, API_ShellBaseType, API_MorphType and API_WallType elements. API_MeshType, API_LampType, API_ObjectType and API_SlabType contain the same structure but this feature was not extended for these elements.