Archicad 28 C++ API
|
Represents a slab element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
short | pen |
Pen attribute index of the slab's contour. | |
API_AttributeIndex | ltypeInd |
Line type attribute index of the slab's contour. | |
API_ModelElemStructureType | modelElemStructureType |
The structure type of the slab. | |
API_AttributeIndex | buildingMaterial |
Building Material index of slabs's hatch. Used only, if structure type is API_BasicStrucure . | |
API_AttributeIndex | composite |
Composite index of slab. Used only, if structure type is API_CompositeStructure . | |
short | sectContPen |
Contour pen attribute index of the slab's fill in sections. | |
API_OverriddenPen | cutFillPen |
Cut fill pens set in the used structure (building material, composite) can be overridden on the element level. | |
API_OverriddenPen | cutFillBackgroundPen |
Cut fill pens set in the used structure (building material, composite) can be overridden on the element level. | |
API_OverriddenAttribute | topMat |
Top material attribute override structure. | |
API_OverriddenAttribute | sideMat |
Side material attribute override structure. | |
API_OverriddenAttribute | botMat |
Bottom material attribute override structure. | |
bool | materialsChained |
Are surface materials chained?. | |
double | thickness |
Thickness of the slab. | |
double | level |
Distance of the reference level of the slab from the floor level. | |
API_AttributeIndex | hiddenContourLineType |
Line type of the slab's Hidden Contour. | |
short | hiddenContourLinePen |
Pen of the slab's Hidden Contour line. | |
API_AttributeIndex | sectContLtype |
Line type attribute index of the slab's section contour. | |
API_SlabReferencePlaneLocationID | referencePlaneLocation |
Location of the reference plane. | |
bool | useFloorFill |
Use cover fill? | |
API_StoryVisibility | visibilityCont |
Visibility of slab's contour line. On the element's own story the contour should allways be visible. | |
API_StoryVisibility | visibilityFill |
Visibility of slab's cover fill. | |
API_LinkToSettings | linkToSettings |
Mode of linking to home story. | |
short | floorFillPen |
Pen attribute index of slab's cover fill. | |
short | floorFillBGPen |
Background pen attribute index of the slab's cover fill. | |
API_AttributeIndex | floorFillInd |
Fill attribute index of the slab's cover fill. | |
bool | use3DHatching |
Use Vectorial 3D Hatch patterns in Floor Plan view? This will apply the Vectorial 3D Hatch set for the element's top side material. | |
double | offsetFromTop |
Vertical distance between the reference level and the top of the slab (output only), see API_SlabReferencePlaneLocationID. | |
API_Polygon | poly |
Polygon of the slab. | |
API_HatchOrientation | hatchOrientation |
Orientation and distortion parameters of the cover fill. | |
Represents a slab element.