Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StoryVisibility Struct Reference

Determines the appearance of model elements on different stories. More...

#include <APIdefs_Elements.h>

Public Attributes

bool showOnHome
 Show the element on its own story only.
 
bool showAllAbove
 Show the element on all stories above its own story.
 
bool showAllBelow
 Show the element on all stories below its own story.
 
short showRelAbove
 Show the element on showRelAbove stories above its own story.
 
short showRelBelow
 Show the element on showRelBelow stories below its own story.
 

Detailed Description

Determines the appearance of model elements on different stories.

Remarks
For API_SlabType, API_RoofType and API_MeshType elements you can set a desired number of stories above and below their own story on which to display their contour line and cover fill. API_BeamType and API_ObjectType contain this structure but this new feature was not extended for these elements.