Archicad 28 C++ API
|
Represents a wall element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
short | contPen |
Pen attribute index of wall's contour. | |
short | contPen3D |
The pen index of wall's contour in 3D. | |
API_AttributeIndex | contLtype |
The linetype index of wall's contour. | |
API_AttributeIndex | belowViewLineType |
Line type used when "OutLines Only" is selected from the "Floor Plan Display" popup. Corresponds to the "Uncut Lines" value in the Wall Settings dialog. | |
API_ModelElemStructureType | modelElemStructureType |
The structure type of the wall. | |
API_AttributeIndex | buildingMaterial |
Building Material index of wall's hatch. Used only, if structure type is API_BasicStrucure . | |
API_AttributeIndex | composite |
Composite index of wall. Used only, if structure type is API_CompositeStructure . | |
Int32 | sequence |
Sequence is required when two walls meet with the same priority or when 3 or more walls meet in a junction. It's actual values can be between 0 and 999. | |
API_OverriddenPen | cutFillPen |
Cut fill pens set in the used structure (building material, composite, complex profile) can be overridden on the element level. | |
API_OverriddenPen | cutFillBackgroundPen |
Cut fill pens set in the used structure (building material, composite, complex profile) can be overridden on the element level. | |
API_OverriddenAttribute | refMat |
Material override structure of the surface on the reference line side. | |
API_OverriddenAttribute | oppMat |
Material override structure of the opposite surface. | |
API_OverriddenAttribute | sidMat |
Material override structure of the side surfaces. | |
API_AttributeIndex | profileAttr |
Attribute index of the extruded profile (APIInvalidAttributeIndex if not profiled). See API_ProfileAttrType. | |
short | profileType |
The type of the cross section of the wall: | |
bool | polyCanChange |
The polygon wall's corners can be changed in case of L and T connections. | |
bool | materialsChained |
Are surface materials chained? | |
bool | flipped |
If true then the wall is mirrored to the reference line. (true == APIWdir_Left or APIWdir_LCenter ; false == APIWdir_Right or APIWdir_Center in the old API_WallDirID enum). | |
API_WallTypeID | type |
The type of the geometry of the wall (see API_WallTypeID). | |
API_WallReferenceLineLocationID | referenceLineLocation |
The location of the reference line (see API_WallReferenceLineLocationID). | |
double | height |
The height of the wall relative to its bottom. | |
double | bottomOffset |
Base height of the wall relative to the floor level. | |
double | topOffset |
The offset from top floor if wall is top linked. | |
double | thickness |
The thickness of the wall at the beginning point. | |
double | thickness1 |
The thickness of the wall at the end point. | |
double | offset |
The offset of the wall's base line from reference line at the beginning point (invalid for center wall directions). | |
double | offsetFromOutside |
Distance between reference line and outside face of the wall (output only). | |
double | logHeight |
The height of the log for log walls (0 means normal wall). | |
Int32 | beamFlags |
Log wall relation flags. | |
API_ZoneRelID | zoneRel |
Defines the wall's relation to zones (see API_ZoneRelID). | |
bool | isAutoOnStoryVisibility |
Recalculate the story visibility automatically according to the actual vertical extent of the wall. | |
bool | inheritEndSurface |
The end surface of the wall is inherited from the adjoining wall. | |
bool | alignTexture |
Align texture mapping to wall edges. | |
API_StoryVisibility | visibility |
The option to define which stories display the wall. | |
API_LinkToSettings | linkToSettings |
Mode of linking to home story. | |
short | relativeTopStory |
The top linked story (relative to home story). Negative values are invalid. 0 = not top linked. | |
API_Coord | begC |
The start (beginning) coordinate of the wall. | |
API_Coord | endC |
The end coordinate of the wall. | |
API_Polygon | poly |
The original outline of the wall. | |
Int32 | rLinInd |
The index of the reference line beginning edge (starting from 1). Note that the direction can be reversed if the polygonal wall is mirrored. | |
Int32 | rLinEndInd |
The index of the reference line end edge. | |
Int32 | refInd |
The index of the reference material start edge index. | |
Int32 | refEndInd |
The index of the reference material end edge index. | |
Int32 | oppInd |
The index of the opposite side material edge start. | |
Int32 | oppEndInd |
The index of the opposite side material end edge index. | |
double | angle |
The rotation angle of the wall in radians. | |
bool | hasWindow |
Output only: true, if the Wall has at least one Window. | |
bool | hasDoor |
Output only: true, if the Wall has at least one Door. | |
Int32 | wallConnPriority |
Set the priority of the wall in the junction with other elements. | |
bool | useCompositePriority |
Set the priority of the composits in the junction with other elements. | |
short | aboveViewLinePen |
Pen used when "Overhead All" is selected from the "Floor Plan Display" popup. Corresponds to the "Overhead Line Pens" value in the Wall Settings dialog. | |
API_AttributeIndex | aboveViewLineType |
Line type used when "Overhead All" is selected from the "Floor Plan Display" popup. Corresponds to the "Overhead Lines" value in the Wall Settings dialog. | |
API_ElemDisplayOptionsID | displayOption |
Determines how the wall appears on the floor plan. | |
API_ElemViewDepthLimitationsID | viewDepthLimitation |
Determines which part of the wall is visible for multi-story walls. | |
double | slantAlpha |
Defines the angle for slanted and double slanted walls. | |
double | slantBeta |
Defines the angle for double slanted walls. | |
Represents a wall element.
API_WallType::beamFlags |
Log wall relation flags.
Flag | Meaning |
---|---|
APIWBeam_RefMater | Apply Reference side material on horizontal edges. |
APIWBeam_OppMater | Apply Opposite side material on horizontal edges. |
APIWBeam_HalfLog | Start with half log. |
APIWBeam_QuadricLog | Use square (quadric) logs. |
APIWBeam_Stretched | The log radius is measured from the opposite side. |
APIWBeam_RightLog | The logs are curved on the right side of the wall. |
APIWBeam_LeftLog | The logs are curved on the left side of the wall. |
API_WallType::profileType |
The type of the cross section of the wall:
Profile type | Meaning |
---|---|
APISect_Normal | Simple cross section element |
APISect_Poly | Profiled cross section element |
APISect_Slanted | Slanted cross section element |
APISect_Trapez | Trapezoid cross section element |