Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RoomReductionPolyType Struct Reference

Parameters to get room reduction data. More...

#include <APIdefs_Database.h>

Public Attributes

short type
 Type of the polygon.
 
short percent
 Percentage of the polygon area.
 
Int32 nCoords
 Number of coordinates.
 
Int32 nSubPolys
 Number of the subpolygons.
 
Int32 nArcs
 Number of the arcs.
 
API_Coord ** coords
 The coordinate array.
 
Int32 ** subPolys
 The subpolygon endpoints.
 
API_PolyArc ** arcs
 The polygon arcs.
 
double area
 Area of the polygon.
 

Detailed Description

Parameters to get room reduction data.

Remarks
Refer to the API_Polygon structure to get more details on the polygon structure. See the RoomReductionPolyProc and ACAPI_Element_RoomReductions functions to get more information on how the room reduction data can be obtained. Remember to dispose of the coords, subPolys, and arcs handles if they are not needed anymore.

Member Data Documentation

◆ type

API_RoomReductionPolyType::type

Type of the polygon.

type polygon
APIRoomReduction_Wall wall
APIRoomReduction_Column column
APIRoomReduction_Hatch hatch
APIRoomReduction_Gable low ceiling
APIRoomReduction_Rest other