Archicad 28 C++ API
|
Represents the layout of a Stair element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_StoryVisibility | visibility |
The option to define on which stories are the stairs displayed. | |
bool | isAutoOnStoryVisibility |
It will be true, if showOnHome in visibility is false. | |
API_StairGridTypeID | gridTypeAbove |
Layout above relevant stories: | |
API_StairGridTypeID | gridTypeTop |
Layout on top relevant stories. | |
API_StairGridTypeID | gridTypeMiddle |
Layout on middle stories. | |
API_StairGridTypeID | gridTypeBottom |
Layout on bottom story. | |
API_StairGridTypeID | gridTypeBelow |
Layout below relevant stories. | |
API_StairStoryVisibilityID | storyVisibility |
Visibility type in the story. | |
bool | showWalkingLine |
If true, the walking line is shown. | |
bool | showNumbering |
If true, the stair numbering is shown. | |
bool | showUpDownText |
If true, the stair direction label is shown. | |
bool | showDescription |
If true, the stair description is shown. | |
bool | showStructure |
If true, the stair structures are shown. | |
double | breakLineAngle |
The angle of the break line. | |
Int32 | breakLineAngleNumberOfGoings |
The amount of goings of the break line. | |
API_BreakLineAngleTypeID | breakLineAngleType |
The angle type of the break line: |APIBreakLineAngle_AngleToVertical|Angel to vertical.| |APIBreakLineAngle_AngleToHorizontal|Angle to horizontal.| |APIBreakLineAngle_NumberOfGoings|Angle will be calculated based on the given Number of Goings.|. | |
double | breakLineDistance |
The gap of the break line. | |
API_BreakLinePositionTypeID | breakLinePositionType |
The line position type of the break line: |APIBreakLinePosition_FloorPlanCutPlaneHeight|Break line height is determined from the Floor Plan Cut Plane Height.| |APIBreakLinePosition_CustomHeight|Break line is on Custom Height.| |APIBreakLinePosition_AtNthRiser|Break line is on a given Riser.|. | |
double | upperBreakLineCustomPosition |
Custom position of the upper break line. | |
double | lowerBreakLineCustomPosition |
Custom position of the lower break line. | |
UInt32 | upperBreakLineNthRiserPosition |
Riser position of the upper break line. | |
UInt32 | lowerBreakLineNthRiserPosition |
Riser position of the lower break line. | |
bool | overrideLineType |
If true, the line type will be overridden. | |
bool | overridePen |
If true, the line pen will be overridden. | |
short | pen |
The line pen index for the Stair. | |
API_AttributeIndex | lineType |
The line type index for the Stair. | |
bool | overrideSymbolFill |
If true, the fill will be overridden. | |
API_AttributeIndex | symbolFill |
The symbol fill type index for the Stair. | |
short | symbolFillPen |
The sybol fill pen index for the Stair. | |
short | symbolFillBkgPen |
The symbol fill background pen index for the Stair. | |
Represents the layout of a Stair element.
API_StairLayoutData::breakLineAngleType |
The angle type of the break line: |APIBreakLineAngle_AngleToVertical|Angel to vertical.| |APIBreakLineAngle_AngleToHorizontal|Angle to horizontal.| |APIBreakLineAngle_NumberOfGoings|Angle will be calculated based on the given Number of Goings.|.
API_StairLayoutData::breakLinePositionType |
The line position type of the break line: |APIBreakLinePosition_FloorPlanCutPlaneHeight|Break line height is determined from the Floor Plan Cut Plane Height.| |APIBreakLinePosition_CustomHeight|Break line is on Custom Height.| |APIBreakLinePosition_AtNthRiser|Break line is on a given Riser.|.
API_StairLayoutData::gridTypeAbove |
Layout above relevant stories:
Type | Meaning |
---|---|
APIStairGrid_NotRelevant | Not Relevant. |
APIStairGrid_WithSingleBreaklineFull | With Break Mark: Visible - Hidden |
APIStairGrid_NoBreaklineFull | No Break Mark: Visible |
APIStairGrid_BelowBreakline | Below Break Mark: Visible |
APIStairGrid_AboveBreakline | Above Break Mark: Visible |
APIStairGrid_MiddleBreakline | Multistory 2D: Visible Inbetween Break Marks |
APIStairGrid_MiddleBreaklineFull | Multistory 2D: Hidden - Visible - Hidden |
APIStairGrid_NoBreakMarkHidden | No Break Mark: Hidden |
APIStairGrid_AboveBreakMarkHidden | Above Break Mark: Hidden |
APIStairGrid_BelowBreakMarkHidden | Below Break Mark: Hidden |
APIStairGrid_Multistory2DAllVisible | Multistory 2D: All Visible |
APIStairGrid_Multistory2DHiddenVisible | Multistory 2D: Hidden - Visible - None |
APIStairGrid_Multistory2DNoneVisibleHidden | Multistory 2D: None - Visible - Hidden |
APIStairGrid_WithBreakMarkAllVisible | With Break Mark: All Visible |
APIStairGrid_WithBreakMarkHiddenVisible | With Break Mark: Hidden - Visible |