Archicad 28 C++ API
|
Represents a Stair Structure element. More...
#include <APIdefs_Elements.h>
Public Attributes | ||
API_Elem_Head | head | |
General element header. | ||
API_Guid | owner | |
GUID of the owning stair. | ||
API_Guid | libId | |
Library part GUID. | ||
UInt32 | sequenceNumber | |
The number of the step that the structure element belongs to. | ||
UInt32 | subElemId | |
The subelement identifier of the structure element. | ||
bool | visible | |
True, if the object is visible. | ||
bool | isLanding | |
True, if the structure is a landing. | ||
API_StairStructureTypeID | structType | |
The type of the stair structure: |APIST_Side|The Stair is supported at its sides.| |APIST_Monolith|The Stair has a solid block under it.| |APIST_BeamSupport|The Stair is supported by beams.| |APIST_CantileveredSupport|The Stair is supported at only one side.|. | ||
API_StairStructBottomTypeID | bottomType | |
The type of the stair structure bottom: |APISB_Stepped|The stair structure is stepped along with the steps.| |APISB_Flat|The stair structure is flattened under the steps.| |APISB_Smooth|The stair structure is monolithic.|. | ||
double | horizontalThickness | |
The horizontal thickness of the stair structure. | ||
double | thickness | |
The thickness of the stair structure. | ||
union { | ||
API_SideStairStructData sideStair | ||
Data of the side supported structures. | ||
API_MonolithStairStructData monolith | ||
Data of the monolithic structures. | ||
} | data | |
Data of the monolithic or side supported structure. | ||
API_StairPartRoleID | role | |
Role of the Stair subelement. | ||
API_StairStructureSideID | side | |
Supported side of the Stair: |APISS_LeftSide|The stair structure supports the step from the left side.| |APISS_RightSide|The stair structure supports the step from the right side.| |APISS_UnderSide|The stair structure supports the step from under.|. | ||
Represents a Stair Structure element.
API_StairStructureType::bottomType |
The type of the stair structure bottom: |APISB_Stepped|The stair structure is stepped along with the steps.| |APISB_Flat|The stair structure is flattened under the steps.| |APISB_Smooth|The stair structure is monolithic.|.
API_StairStructureType::side |
Supported side of the Stair: |APISS_LeftSide|The stair structure supports the step from the left side.| |APISS_RightSide|The stair structure supports the step from the right side.| |APISS_UnderSide|The stair structure supports the step from under.|.
API_StairStructureType::structType |
The type of the stair structure: |APIST_Side|The Stair is supported at its sides.| |APIST_Monolith|The Stair has a solid block under it.| |APIST_BeamSupport|The Stair is supported by beams.| |APIST_CantileveredSupport|The Stair is supported at only one side.|.