Archicad 28 C++ API
|
Represents the data of a monolithic Stair Structure element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
bool | thinning |
True, if the structure is thinned. | |
bool | materialsChained |
True, if the structure's materials are chained. | |
API_AttributeIndex | sideFill |
The fill of the building material. | |
API_AttributeIndex | buildingMaterial |
The index of the structure's building material. | |
double | monolithThickness |
The thickness of the monolith. | |
double | bottomOversize |
The size of the horizontal bottom. | |
API_OverriddenAttribute | topMaterial |
The top material of the structure. | |
API_OverriddenAttribute | leftMaterial |
The left side material of the structure. | |
API_OverriddenAttribute | rightMaterial |
The right side material of the structure. | |
API_OverriddenAttribute | bottomMaterial |
The bottom material of the structure. | |
API_AttributeIndex | cutLineType |
The index of the cut parts' 2D representation's line type. | |
short | cutLinePen |
The index of the cut parts' 2D representation's pen. | |
short | pen |
The index of the 2D representation's pen. | |
API_AttributeIndex | lineType |
The index of the 2D representation's line type. | |
API_OverriddenPen | cutFillPen |
The cut fill pen of the Stair Structure. | |
API_OverriddenPen | cutFillBackgroundPen |
The cut fill background pen of the Stair Structure. | |
API_AttributeIndex | surfaceMaterial |
The Stair Structure's surface material. | |
bool | uniformDrainings |
Uniform Drainings on left and right side. | |
API_StairStructureDrainingData | draining [API_StairDrainSideNum] |
Data about the Stair Structure's drainings. |APIDS_Left|Draining on the left side.| |APIDS_Right|Draining on the right side.|. | |
Represents the data of a monolithic Stair Structure element.
API_MonolithStairStructData::draining |
Data about the Stair Structure's drainings. |APIDS_Left|Draining on the left side.| |APIDS_Right|Draining on the right side.|.