Archicad 28 C++ API
|
Structure for retrieving connection data of a wall. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Coord ** | coords |
Coordinates of the modified outline polygon. | |
Int32 ** | pends |
Indices of the end coordinates of the subpolygons. | |
API_PolyArc ** | parcs |
Arc segments of the modified outline polygon. | |
API_Polygon | connPoly |
Modified outline polygon due to the connections. | |
API_ConnectionGuidItem ** | conBeg |
List of walls connected to the beginning point of the wall with their beginning or end point. | |
API_ConnectionGuidItem ** | conEnd |
List of walls connected to the end point of the wall with their beginning or end point. | |
API_ConnectionGuidItem ** | conRef |
List of walls connected with their reference line to the beginning or the end point of the wall. | |
API_ConnectionGuidItem ** | con |
List of walls connected to the reference line of the wall not at the endpoints. +/- values: connection with their beg/end point. | |
API_ConnectionGuidItem ** | conX |
List of walls having intersections with the reference line of the wall. | |
Int32 | nConBeg |
Number of conBeg indices. | |
Int32 | nConEnd |
Number of conEnd indices. | |
Int32 | nConRef |
Number of conRef indices. | |
Int32 | nCon |
Number of con indices. | |
Int32 | nConX |
Number of conX indices. | |
Structure for retrieving connection data of a wall.