Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ConnectionGuidItem Struct Reference

Represents a wall or beam connection. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Guid guid
 guid of the wall, beam, or beam segment connected with its reference line to the given element.
 
bool conWithBeg
 The wall, beam, or beam segment is connected with its beginning or the end point.
 

Detailed Description

Represents a wall or beam connection.

Remarks
For more details see API_WallRelation, API_BeamRelation, and API_BeamSegmentRelation structures.