Archicad 27 C++ API
Loading...
Searching...
No Matches
API_BeamRelation Struct Reference

Structure for retrieving connection data of a beam. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Coord ** coords
 Coordinates of the modified outline polygon.
 
Int32 ** pends
 Indices of the end coordinates of the subpolygons.
 
API_PolyArc ** parcs
 Arc segments of the modified outline polygon (used with curved beams.
 
API_Polygon connPoly
 Modified outline polygon due to the connections.
 
GS::Array< API_ConnectionGuidItem > * conBeg
 List of beams connected to the beginning point of the beam with their beginning or end point (see figure).
 
GS::Array< API_ConnectionGuidItem > * conEnd
 List of beams connected to the end point of the beam with their beginning or end point (see figure).
 
GS::Array< API_ConnectionGuidItem > * conRef
 List of beams connected with their reference line to the beginning or the end point of the beam (see figure).
 
GS::Array< API_ConnectionGuidItem > * con
 List of beams connected to the reference line of the beam not at the endpoints (see figure). +/- values: connection with beginning/end point.
 
GS::Array< API_ConnectionGuidItem > * conX
 List of beams having intersection with the reference line of the beam (see figure).
 
GS::Array< API_BeamSegmentRelation > * segmentRelations
 List of relations of the beam's segments.
 

Detailed Description

Structure for retrieving connection data of a beam.

Remarks
To learn more about the usage of the beam relation structure please refer to the ACAPI_Element_GetRelations function. Explanatory figure for beam relation cases:
Beam relation