Archicad 28 C++ API
|
Structure for retrieving connection data of a beam segment. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Coord ** | coords |
Coordinates of the modified outline polygon. | |
Int32 ** | pends |
Indices of the end coordinates of the subpolygons. | |
API_PolyArc ** | parcs |
Arc segments of the modified outline polygon (used with curved beams. | |
API_Polygon | connPoly |
Modified outline polygon due to the connections. | |
GS::Array< API_ConnectionGuidItem > * | conBeg |
List of beam segments connected to the beginning point of the beam segment with their beginning or end point. | |
GS::Array< API_ConnectionGuidItem > * | conEnd |
List of beam segments connected to the end point of the beam segment with their beginning or end point. | |
GS::Array< API_ConnectionGuidItem > * | conRef |
List of beam segments connected with their reference line to the beginning or the end point of the beam segment. | |
GS::Array< API_ConnectionGuidItem > * | con |
List of beam segments connected to the reference line of the beam segment not at the endpoints. +/- values: connection with beginning/end point. | |
GS::Array< API_ConnectionGuidItem > * | conX |
List of beam segments having intersection with the reference line of the beam segment. | |
Structure for retrieving connection data of a beam segment.