Archicad 28 C++ API
Loading...
Searching...
No Matches
API_WindowInfo Struct Reference

Identification parameters of a project window. More...

#include <APIdefs_Database.h>

Public Attributes

API_WindowTypeID typeID
 the window/database type identifier
 
Int32 index
 usually the database/window index (the refCon value in case of custom windows, not used for Section/Elevation Detail and Worksheet database/window).
 
API_DatabaseUnId databaseUnId
 Section/Elevation/Interior Elevation, Detail and Worksheet database/window unique identifier.
 
API_DatabaseUnId masterLayoutUnId
 for Layouts only; database unique ID of the master layout
 
GS::uchar_t title [API_UniLongNameLen]
 the title of the database (Unicode string), as it is displayed on the window title bar (generally "ref"+" "+"name")
 
GS::uchar_t name [API_UniLongNameLen]
 the name of the database (Unicode string)
 
GS::uchar_t ref [API_UniLongNameLen]
 reference string/id of the database
 
API_Guid linkedElement
 Element linked to the database (e.g., section to a section database) except for drawing databases where it is the drawing element's guid.
 
API_DatabaseUnId linkedDatabaseUnId
 For databases linked to elements (section, detail, etc.): the database containing the element.
 
Int32 linkedSegmentMemoIndex
 For interior elevations only; the section segment index in the element memo.
 

Detailed Description

Identification parameters of a project window.

Remarks
Database/Window reference is used for several purposes: