Archicad 28 C++ API
|
Represents a zone stamp. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
short | pen |
Pen attribute index for the zone stamp. Used only if useStampPens is false. | |
API_AttributeIndex | catInd |
Index of the actual zone category. | |
bool | useStampPens |
Draw with a single pen (false) or use the pens defined in the zone category library part (true)? | |
bool | manual |
Manually created zone; all edges static, no reference point (refPos). | |
bool | refLineFlag |
Surrounded by walls' reference lines, not side lines. | |
bool | show_found_poly |
If true, then Archicad uses the reference line of the walls surrounding the zone for calculations; otherwise it uses the inner edges of the walls. (Can be used only if refLineFlag is true.) | |
GS::uchar_t | roomName [API_UniLongNameLen] |
Name of the room as a Unicode string. | |
GS::uchar_t | roomNoStr [32] |
Room number as a Unicode string. | |
double | roomBaseLev |
Base level of the room, measured from the floor level. | |
double | roomHeight |
Height of the room. | |
double | roomTopOffset |
The offset from top floor if zone is top linked. | |
double | roomFlThick |
Sub-floor thickness of the room. | |
double | roomLSize |
Room letter size in mm. | |
double | reducePercent |
Reduce the zone area with this value [%]. | |
API_AttributeIndex | material |
Material attribute index of the 3D zone's (free or all) surfaces. | |
double | stampAngle |
Rotation angle of the room stamp [radian]. | |
bool | fixedAngle |
The stampAngle will not change when the element is rotated and this flag is true. | |
bool | oneMat |
Use material for all surfaces if true; otherwise inherit boundary walls' and trimming elements' materials. | |
short | floorFillPen |
Pen attribute index of zone's cover fill. | |
API_AttributeIndex | floorFillInd |
Fill attribute index of the zone's cover fill. | |
short | floorFillBGPen |
Background pen attribute index of the zone's cover fill. | |
short | floorContLPen |
Pen attribute index of zone's contour. | |
API_AttributeIndex | floorContLType |
Line type attribute index of zone's contour. | |
bool | useContourLine |
Draw contour line? | |
bool | useLocalOrigo |
Use local origo for cover fill drawing? | |
bool | use3DHatching |
Use Vectorial 3D Hatch patterns in Floor Plan view? This will apply the Vectorial 3D Hatch set for the element's top side material. | |
bool | useFloorFill |
Use cover fill? | |
Int32 | libInd |
Index to the zone category library part in the library. | |
API_LinkToSettings | linkToSettings |
Mode of linking to home story. | |
short | relativeTopStory |
The top linked story (relative to home story). Negative values are invalid. 0 = not top linked. | |
API_Polygon | poly |
Polygon of the zone. | |
API_Coord | pos |
Position of the origin of the zone stamp. | |
API_Coord | refPos |
Reference point to find zone if it was not created manually. | |
API_Coord | locOrigo |
Base coordinate of zone's cover fill reference vector if it's linked to the element. | |
double | fillAngle |
Angle of zone's cover fill reference vector if it's linked to the element. | |
API_Polygon | refPoly |
The found polygon of the zone. You can access the geometry through the API_ElementMemo of the zone. | |
API_Guid | stampGuid |
GUID of the zone stamp object. | |
Represents a zone stamp.