Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ListData Union Reference

The representation of a listdata. More...

#include <APIdefs_ListData.h>

Public Attributes

API_ListData_Head header
 A common header for all the listdata types. It contains information which applies to all the listdata types.
 
API_KeyType key
 a key listdata
 
API_UnitType unit
 an unit listdata
 
API_Obsolete_ComponentType component
 a component listdata
 
API_DescriptorType descriptor
 a descriptor listdata
 

Detailed Description

The representation of a listdata.

Remarks
This union is used when you get or search in the listing database. See the ACAPI_OldListing_Get, ACAPI_OldListing_GetLocal, ACAPI_OldListing_Search functions.