Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::ElementBase Class Reference

A base class for all elements. More...

#include <ElementBase.hpp>

Inheritance diagram for ACAPI::v1::ElementBase:
ACAPI::v1::Object ACAPI::MEP::v1::ElementBase ACAPI::MEP::v1::RoutingElement ACAPI::MEP::v1::RoutingNode ACAPI::MEP::v1::RoutingSegment ACAPI::MEP::v1::Bend ACAPI::MEP::v1::Element ACAPI::MEP::v1::ModifiableElementBase ACAPI::MEP::v1::RigidSegment ACAPI::MEP::v1::Transition ACAPI::MEP::v1::Accessory ACAPI::MEP::v1::Branch ACAPI::MEP::v1::Equipment ACAPI::MEP::v1::Fitting ACAPI::MEP::v1::FlexibleSegment ACAPI::MEP::v1::ModifiableElement ACAPI::MEP::v1::TakeOff ACAPI::MEP::v1::Terminal

Public Member Functions

UniqueID GetElemId () const
 Get unique identifier of the ElementBase object.
 
Result< void > IsEditable () const
 Checks whether the element is editable.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Protected Member Functions

 ElementBase (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new ElementBase.
 
- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 

Additional Inherited Members

- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

A base class for all elements.

Constructor & Destructor Documentation

◆ ElementBase()

ACAPI::v1::ElementBase::ElementBase ( std::shared_ptr< Impl::ObjectImpl impl)
protected

Constructs a new ElementBase.

Parameters
implImpl instance of the object.

Member Function Documentation

◆ GetElemId()

UniqueID ACAPI::v1::ElementBase::GetElemId ( ) const

Get unique identifier of the ElementBase object.

Returns
Unique identifier of the ElementBase object.

◆ IsEditable()

Result< void > ACAPI::v1::ElementBase::IsEditable ( ) const

Checks whether the element is editable.

Returns
Returns nothing if the element is editable, otherwise the error code and error message containing information about the reason.