Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::ZoneBoundary Class Reference

Represents a boundary between a Zone and another element. A boundary is the intersection of the coplanar surfaces of the Zone body and the boundary element. The surface will be split into multiple boundaries if it is connected to multiple Zones, one boundary for each Zone. A boundary can be either internal or external. An internal boundary is between two Zones, otherwise it is external. More...

#include <ZoneBoundary.hpp>

Inheritance diagram for ACAPI::v1::ZoneBoundary:
ACAPI::v1::Object

Public Member Functions

API_Guid GetElemId () const
 
API_Guid GetNeighbouringZoneId () const
 
bool IsExternal () const
 
ModelerAPI::MeshBody GetBody () const
 
ModelerAPI::Polygon GetPolygon () const
 
double GetArea () const
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class Impl::ObjectCreator
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents a boundary between a Zone and another element. A boundary is the intersection of the coplanar surfaces of the Zone body and the boundary element. The surface will be split into multiple boundaries if it is connected to multiple Zones, one boundary for each Zone. A boundary can be either internal or external. An internal boundary is between two Zones, otherwise it is external.

Since
Archicad 27

Member Function Documentation

◆ GetArea()

double ACAPI::v1::ZoneBoundary::GetArea ( ) const
Returns
Returns the area of the polygon of the boundary.

◆ GetBody()

ModelerAPI::MeshBody ACAPI::v1::ZoneBoundary::GetBody ( ) const
Returns
Returns the body in which the polygon of the boundary can be interpreted.

◆ GetElemId()

API_Guid ACAPI::v1::ZoneBoundary::GetElemId ( ) const
Returns
Returns the unique identifier of the connected element.

◆ GetNeighbouringZoneId()

API_Guid ACAPI::v1::ZoneBoundary::GetNeighbouringZoneId ( ) const
Returns
Returns the unique identifer of the other Zone the element connects to if the boundary is internal. Returns APINULLGuid if the boundary is external. Please note that this boundary does not represent the boundary of the element with the other Zone.

◆ GetPolygon()

ModelerAPI::Polygon ACAPI::v1::ZoneBoundary::GetPolygon ( ) const
Returns
Returns the polygon of the boundary.

◆ IsExternal()

bool ACAPI::v1::ZoneBoundary::IsExternal ( ) const
Returns
Returns wheter the boundary is an external one.