Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::ZoneBoundaryQuery Class Reference

This class can be used to query the boundaries of Zones. Before use an Update must be called on it. More...

#include <ZoneBoundaryQuery.hpp>

Inheritance diagram for ACAPI::v1::ZoneBoundaryQuery:
ACAPI::v1::Object

Public Member Functions

Result< std::vector< ZoneBoundary > > GetZoneBoundaries (API_Guid zoneId) const
 
template<typename ModifierFunc >
Result< void > Modify (ModifierFunc &&modifierFunc)
 Executes the given modifier scope in a NotUndoable command.
 
Result< void > Update (GS::ProcessControl &)
 Updates the boundaries of the Zones in the current view. Works only on Floor Plan window and 3D Model window.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

ZoneBoundaryQuery CreateZoneBoundaryQuery ()
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

This class can be used to query the boundaries of Zones. Before use an Update must be called on it.

Since
Archicad 27

Member Function Documentation

◆ GetZoneBoundaries()

Result< std::vector< ZoneBoundary > > ACAPI::v1::ZoneBoundaryQuery::GetZoneBoundaries ( API_Guid  zoneId) const
Parameters
zoneIdThe unique identifier of the Zone.
Returns
Returns the boundaries of the given Zone if it exists, otherwise Error.

◆ Modify()

template<typename ModifierFunc >
Result< void > ACAPI::v1::ZoneBoundaryQuery::Modify ( ModifierFunc &&  modifierFunc)

Executes the given modifier scope in a NotUndoable command.

Parameters
modifierFuncThe modifier scope (lambda, std::function or function pointer) the caller wants to execute.
Returns
Returns an error if the process of modification fails for some reason, otherwise nothing.

◆ Update()

Result< void > ACAPI::v1::ZoneBoundaryQuery::Update ( GS::ProcessControl &  )

Updates the boundaries of the Zones in the current view. Works only on Floor Plan window and 3D Model window.

Returns
Returns an error if the current window is not Floor Plan or 3D Model.

Friends And Related Symbol Documentation

◆ CreateZoneBoundaryQuery

ZoneBoundaryQuery CreateZoneBoundaryQuery ( )
friend
Since
Archicad 27
Returns
Creates a ZoneBoundaryQuery object.