Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ColumnSegmentType Struct Reference

Represents an segment of the column element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_Guid owner
 Guid of the owner column.
 
API_AssemblySegmentData assemblySegmentData
 General informations about segment.
 
API_OverriddenAttribute extrusionSurfaceMaterial
 The column's segment material override structure.
 
API_OverriddenAttribute endsMaterial
 The material override structure of the beginning and end side of the column's segment.
 
bool materialsChained
 Are surface materials chained?
 
API_AttributeIndex venBuildingMaterial
 Building Material index of column's segment veneer's hatch. Used only, if structure type is API_BasicStrucure.
 
API_VeneerTypeID venType
 The type of the column's segment veneer.
 
double venThick
 The thickness of the column's segment veneer.
 

Detailed Description

Represents an segment of the column element.