Archicad 27 C++ API
Loading...
Searching...
No Matches
API_DimElem Struct Reference

Describes a dimension element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_DimBase base
 The dimensioned point.
 
API_NoteType note
 Parameters of the dimension text.
 
double witnessVal
 Gap (APIWtn_Fix) or length (APIWtn_Large) of witness line according to witnessForm.
 
API_WitnessID witnessForm
 Witness line format (see API_WitnessID).
 
bool fixedPos
 Fixed position (pos needed for calculation in this case only)
 
API_Coord pos
 Position of Dimension.
 
double dimVal
 Distance from previous DimElem (output only).
 
API_Coord3D pos3D
 Corresponding coordinate on the dimension line in 3D.
 

Detailed Description

Describes a dimension element.