Archicad 28 C++ API
|
Describes a (linear) dimension. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
short | linPen |
Pen attribute index of dimension and witness lines. | |
API_TextPosID | textPos |
Dimension text position (see API_TextPosID ). | |
API_DirID | textWay |
The position of the text relative to the dimension line (see API_DirID ). The possible values are: @ref APIDir_Parallel , APIDir_Horizontal , APIDir_Vertical , APIDir_ArcDim . | |
API_AppearID | dimAppear |
Appearance of the dimension (see API_AppearID ). | |
bool | detailedHoleDim |
Detailed door/window dimension. | |
char | nominalHoleDim |
Nominal height for door/window dimension. | |
char | compAutoThick |
Dimension type bits of composite walls (totalBit = 1; coreBit = 2; refLineBit = 4; manualBit = 16;). | |
bool | defStaticDim |
Static dimension (default)? | |
API_WitnessID | defWitnessForm |
Default witness line format (see API_WitnessID ). | |
double | defWitnessVal |
Default gap (APIWtn_Fix ) or length (APIWtn_Large ) of witness line according todefWitnessForm . | |
API_NoteType | defNote |
Default note parameters (see API_NoteType). | |
API_MarkerData | markerData |
Marker specification (see API_MarkerData). | |
char | ed_dimForm |
Elevation dimension marker type. | |
char | ed_arrowAng |
Elevation dimension half-arrow angle: | |
bool | ed_arrowFill |
Elevation dimension arrow is filled or not. | |
bool | ed_arrowUp |
Elevation dimension arrow is up/down. | |
bool | ed_needPlus |
Elevation dimension plus sign needed for positive numbers. | |
bool | usedIn3D |
Used for dimensioning 3D points. | |
bool | horizontalText |
Dimension texts are horizontal. | |
bool | onlyDimensionText |
Only dimension texts (notes) are visible — no leader line. | |
API_DimOriginID | ed_origin |
Elevation dimension origin. | |
API_CircleLevelDimensionFillID | ed_circleLevelDimensionFill |
Elevation dimension: the circle style marker fill. | |
API_Coord | refC |
Dimension line location. | |
API_Vector | direction |
Direction of the dimension line if parallel. | |
API_DimBase | arcBase |
Neig unique ID of the base element for an arc dimension chain. | |
Int32 | nDimElem |
Number of segments in dimension elements' chain (see API_ElementMemo) | |
API_Coord3D | refC3D |
Position of the dimension chain (used only in 3D). | |
API_Vector3D | direction3D |
Direction of the dimension line (used only in 3D). | |
API_Vector3D | normVect3D |
Dimension plane's normal vector (used only in 3D). | |
API_DimLayoutID | dimLayout |
Layouting algorithm used by the dimension. | |
bool | pushNeighborEnabled |
Enable a note to push its neighbours (In case of API_Flexible layouting algorithm). | |
bool | placeUnderEnabled |
Try to place a note under the dimension line (In case of API_Flexible layouting algorithm). | |
bool | advanced |
Use advanced logic (In case of API_Centered layouting algorithm). | |
bool | clipOtherSide |
No witness line part on the other side (opposite to basepoint). | |
API_DimTextFillOrderID | textFillOrder |
Drawing order of the text's fill and contour relative to the dimension line. | |
Describes a (linear) dimension.
API_DimensionType::compAutoThick |
Dimension type bits of composite walls (totalBit = 1; coreBit = 2; refLineBit = 4; manualBit = 16;).
API_DimensionType::ed_arrowAng |
Elevation dimension half-arrow angle:
Value | Degree |
---|---|
0 | 30 degrees |
1 | 45 degrees |
2 | 60 degrees |