Archicad 28 C++ API
|
Represents a hatch element. More...
#include <APIdefs_Elements.h>
Public Attributes | |
API_Elem_Head | head |
General element header. | |
API_ExtendedPenType | contPen |
Pen attribute index of the hatch contour (0 if contour is switched off). | |
API_HatchSubType | hatchType |
Subtype of the hatch. | |
UInt32 | hatchFlags |
Flags to modify hatch display. See API_HatchFlags for possible values. | |
API_ExtendedPenType | fillPen |
Pen attribute index of the hatch fill. | |
short | fillBGPen |
Pen attribute index of hatch fill background. | |
API_AttributeIndex | fillInd |
Fill attribute index of the hatch. Used only is case of API_FillHatch . | |
API_AttributeIndex | buildingMaterial |
Building Material attribute index of the hatch. Used only is case of API_BuildingMaterialHatch .. | |
API_AttributeIndex | ltypeInd |
Line type attribute index. | |
char | roomSpecial |
Special area percent in a room (negative means OFF). | |
bool | showArea |
True if area text is shown (parameters in note). | |
short | determination |
How to determine the type of this fill (cover, cut, drafting) | |
double | penWeight |
Pen weight of the contour (overrides the weight defined in contPen ). | |
API_NoteType | note |
Parameters of the area text. | |
API_Polygon | poly |
Polygon of the hatch element. | |
API_HatchOrientation | hatchOrientation |
Orientation and distortion parameters of the cover fill. | |
API_RGBColor | backgroundRGB |
RGB color for background painting. | |
API_RGBColor | foregroundRGB |
RGB color for foreground painting. | |
Represents a hatch element.
polyFill
field is removed from the structure, and the global
, refPos
, and refAngle
parameters are placed into a separate structure (API_HatchOrientation). Along this line, in Archicad 13 the gradient fill parameters were also moved to the same structure. The hasForegroundRGB
and hasBackgroundRGB
parameters are placed into a separate structure (API_HatchFlags
). In Archicad 20 the contPen
and fillPen
parameters are placed into a separate structure (API_ExtendedPenType). API_HatchType::determination |
How to determine the type of this fill (cover, cut, drafting)
Determination | Meaning |
---|---|
APIHatch_DraftingFills | Default fill category. Drafting fills adopt the Drafting Fill settings chosen in Display Options. |
APIHatch_CoverFills | The Cover Fill category is assigned to the fills of Slabs, Roofs, Meshes and Zones on the floor plan. Cover fills adopt the Element Cover Fill settings chosen in Display |
Options.| |APIHatch_CutFills|The Cut Fill category is assigned to the fills of Cut Elements. Cut fills adopt the Cut Fill settings chosen in Display Options.|