Archicad 27 C++ API
Loading...
Searching...
No Matches
API_IFCProperty Struct Reference

IFC property container structure. More...

#include <APIdefs_Properties.h>

Public Attributes

API_IFCPropertyHead head
 Property header information.
 
API_IFCPropertySingleValue singleValue
 IfcPropertySingleValue values.
 
API_IFCPropertyBoundedValue boundedValue
 IfcPropertyBoundedValue values.
 
API_IFCPropertyListValue listValue
 IfcPropertyListValue values.
 
API_IFCPropertyEnumeratedValue enumeratedValue
 IfcPropertyEnumeratedValue values.
 
API_IFCPropertyTableValue tableValue
 IfcPropertyTableValue values.
 

Detailed Description

IFC property container structure.

Remarks
This structure contains the data of an Ifc(Simple)Property. head contains common information for each type. head.propertyType determines which value member contains value data.