Archicad 27 C++ API
Loading...
Searching...
No Matches
API_RuledShellData Struct Reference

This structure holds the Ruled Shell specific data of API_ShellType. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Polygon shellShape1
 Specification of the first profile polygon. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo.
 
API_Tranmat plane1
 Plane of the first profile.
 
API_Polygon shellShape2
 Specification of the second profile polygon. The shape data arrays are held in the second API_ShellShapeData record of shellShapes in API_ElementMemo..
 
API_Tranmat plane2
 Plane of the second profile.
 
API_ContourEdgeData begShapeEdgeData
 Edge information for the starting plane of the shell.
 
API_ContourEdgeData endShapeEdgeData
 Edge information for the end plane of the shell.
 
API_ContourEdgeData ruledEdgeDatas [2]
 Edge information for the edges connecting points of the starting and end plane.
 
API_MorphingRuleID morphingRule
 Morphing method for shape generation: paired segments or smooth.
 

Detailed Description

This structure holds the Ruled Shell specific data of API_ShellType.

Remarks
For shell related memo data see the ACAPI_Element_GetMemo function.