Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ShellType Struct Reference

Represents a shell element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Elem_Head head
 General element header.
 
API_ShellClassID shellClass
 Shell class:
 
API_ShellBaseType shellBase
 Parameters common with all shell-based element types.
 
API_Tranmat basePlane
 Base plane of the shell element.
 
bool isFlipped
 It tells what way (inside or out) the thickness must be applied from the shell's surfaces.
 
bool hasContour
 The shell has body contour data. If the shell is cut with a body contour polygon, the data of the contour is stored in the first (0-indexed) record of the shellContours array of API_ElementMemo.
 
UInt32 numHoles
 Number of the shell hole contours. The data of the hole contours are stored in the shellContours array of API_ElementMemo, starting after the body contour if there is one, or from the first record if no body contour is given.
 
API_ShellBaseContourEdgeTypeID defEdgeType
 Default edge type for the shell element (see API_ShellBaseContourEdgeTypeID).
 
union { 
 
   API_ExtrudedShellData   extrudedShell 
 Extruded Shell specific data.
 
   API_RevolvedShellData   revolvedShell 
 Revolved Shell specific data.
 
   API_RuledShellData   ruledShell 
 Ruled Shell specific data.
 
u 
 

Detailed Description

Represents a shell element.

Remarks
For shell related memo data see the ACAPI_Element_GetMemo function.

Member Data Documentation

◆ shellClass

API_ShellType::shellClass

Shell class:

API_ShellClassID value Meaning
API_ExtrudedShellID Extruded shell type, use the API_ExtrudedShellData member of the union
API_RevolvedShellID Revolved shell type, use the API_RevolvedShellData member of the union
API_RuledShellID Ruled shell type, use the API_RuledShellData member of the union