Archicad 28 C++ API
|
This structure holds the Extruded Shell specific data of API_ShellType. More...
#include <APIdefs_Elements.h>
Public Attributes | |
double | slantAngle |
Angle of the extrusion vector from the horizontal plane. | |
double | shapePlaneTilt |
Parameter of the plane of the extruded profile. | |
double | begPlaneTilt |
Parameter of the starting plane of the extrusion. | |
double | endPlaneTilt |
Parameter of the end plane of the extrusion. | |
API_Polygon | shellShape |
Profile polygon specification to extrude. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo. | |
API_Coord3D | begC |
Start the extrusion from here (3D point). | |
API_Vector3D | extrusionVector |
Extrude the profile in this direction (3D vector). | |
API_Vector | shapeDirection |
Direction of the profile (2D vector). | |
API_ContourEdgeData | begShapeEdgeData |
Edge information for the starting plane of the shell. | |
API_ContourEdgeData | endShapeEdgeData |
Edge information for the end plane of the shell. | |
API_ContourEdgeData | extrudedEdgeDatas [2] |
Edge information for the edges connecting points of the starting and end plane. | |
This structure holds the Extruded Shell specific data of API_ShellType.