Archicad 28 C++ API
|
This structure holds the Revolved Shell specific data of API_ShellType. More...
#include <APIdefs_Elements.h>
Public Attributes | |
double | slantAngle |
Relative to the plane (radians). | |
double | revolutionAngle |
Angle of view (in radians). | |
double | distortionAngle |
Angle of shear (radians). | |
bool | segmentedSurfaces |
The surface generated by revolving the profile is broken into planes along the revolution arc. | |
API_ShellBaseSegmentTypeID | segmentType |
Curve resolution method: by circle or by arc. | |
Int32 | segmentsByArc |
Number of actual segments if segmentType is APIShellBase_SegmentsByArc . | |
Int32 | segmentsByCircle |
Number of actual segments if segmentType is APIShellBase_SegmentsByCircle . | |
API_Polygon | shellShape |
Profile polygon specification to revolve. The shape data arrays are held in the first API_ShellShapeData record of shellShapes in API_ElementMemo. | |
API_Tranmat | axisBase |
Coord System of axis. | |
API_Vector | distortionVector |
Direction of shear (in axisBase x-y plane).. | |
API_ContourEdgeData | begShapeEdgeData |
edge information for the starting plane of the shell | |
API_ContourEdgeData | endShapeEdgeData |
edge information for the end plane of the shell | |
API_ContourEdgeData | revolvedEdgeDatas [2] |
edge information for the edges connecting points of the starting and end plane. | |
double | begAngle |
Begin angle. | |
This structure holds the Revolved Shell specific data of API_ShellType.