Here is a list of all documented variables with links to the class documentation for each member:
- p -
- pa : API_3DCutShapeType
- pageNumberX : API_DrawingType
- pageNumberY : API_DrawingType
- pageOffset : API_DrawingType
- panelCutLinePen : API_CurtainWallType
- panelCutLineType : API_CurtainWallType
- panelKind : API_PrimElement
- panelsSurface : API_CurtainWallQuantity
- panelsSurfaceE : API_CurtainWallQuantity
- panelsSurfaceN : API_CurtainWallQuantity
- panelsSurfaceNE : API_CurtainWallQuantity
- panelsSurfaceNW : API_CurtainWallQuantity
- panelsSurfaceS : API_CurtainWallQuantity
- panelsSurfaceSE : API_CurtainWallQuantity
- panelsSurfaceSW : API_CurtainWallQuantity
- panelsSurfaceW : API_CurtainWallQuantity
- paragraphs : API_ElementMemo
- parameters : API_OpeningExtrusionGeometryData
- paramInd : API_PrimText
- params : API_ElementMemo, API_ESYMParams, API_GDLModelViewOptions, API_GetParamsType
- parapet : API_DimensionPrefs
- parcs : API_BeamRelation, API_BeamSegmentRelation, API_CWContourData, API_ElementMemo, API_Gable, API_GetPolyType, API_Niche, API_RegularizedPoly, API_ShellContourData, API_ShellShapeData, API_StairBoundaryData, API_StairPolylineData, API_WallRelation
- parent : API_BodyType, API_LabelType
- parentDatabase : API_GhostRecord
- parentGuid : API_LevelDimensionType, API_MarkUpType, API_NavigatorAddOnViewPointData, API_SectElemType
- parentOriginalScale : API_DrawingType
- parentType : API_LabelType, API_LevelDimensionType, API_SectElemType
- parentUnID : API_LibPart
- partialRect : API_RendImage
- partialRendering : API_RendImage
- partId : API_AnalyticalMemberPartRef, API_ElemPartCompositeQuantity, API_ElemPartQuantity
- partLength : API_MagicWandInfo
- partnerID : API_ServerApplicationInfo
- partRefType : API_AnalyticalMemberPartRef
- path : API_AttributeFolder, API_NavigatorSet, API_PublishPars
- pattern : API_CWSegmentPatternData
- patternAmount : API_RailingDistributionData
- patternCellNum : API_CWSegmentType
- pb : API_3DCutShapeType
- pc : API_3DCutShapeType
- pd : API_3DCutShapeType
- peaksLength : API_RoofQuantity, API_ShellQuantity
- pedg : API_Component3D, API_PedgType
- pen : API_CurtainWallType, API_CWAccessoryType, API_CWFrameType, API_CWJunctionType, API_CWPanelType, API_CWSegmentType, API_DetailType, API_DrawingTitle, API_HotspotType, API_LabelType, API_LevelDimensionType, API_LinkType, API_MonolithStairStructData, API_ObjectType, API_OpeningBaseType, API_PersCamSetPars, API_PerspCamPars, API_Prim_Head, API_RunType, API_ShellBaseType, API_SlabType, API_StairLayoutData, API_TextType, API_ZoneType
- pends : API_BeamRelation, API_BeamSegmentRelation, API_CWContourData, API_ElementMemo, API_Gable, API_Niche, API_RegularizedPoly, API_ShellContourData, API_ShellShapeData, API_StairBoundaryData, API_StairPolylineData, API_WallRelation
- penInd : API_NumberingGridLine
- penIndex : API_ExtendedPenType
- pens : API_NavigatorView
- penSetName : API_NavigatorView
- penTable : API_Attribute
- penTable_Items : API_AttributeDefExt
- penTableIndex : API_DrawingType
- penTableUsageMode : API_DrawingType
- penWeight : API_ArcType, API_HatchType, API_LineType, API_PolyLineType, API_PrimArc, API_PrimLine, API_PrimPLine, API_PrimPoly, API_PrimTri, API_SplineType
- percent : API_FilltypeType, API_RoomReductionPolyType
- performSurfaceCheck : API_CollisionDetectionSettings
- perimeter : API_ColumnQuantity, API_CWPanelQuantity, API_HatchQuantity, API_MeshQuantity, API_RoofQuantity, API_ShellQuantity, API_SlabQuantity, API_WallQuantity, API_ZoneAllQuantity
- period : API_LinetypeType
- periodicity : API_Interval
- persp : API_PerspCamPars
- perspCam : API_CameraType
- perspPars : API_CamSetType
- petIconIDsHdl : API_PetPaletteType
- petIconResModule : API_PetPaletteType
- petPaletteID : API_PetPaletteType
- pgon : API_Component3D
- pgon1 : API_EdgeType
- pgon2 : API_EdgeType
- pgonIndex : API_TexCoordPars
- pict : API_PrimElement
- pictHdl : API_ElementMemo, API_PictureHandle
- pictName : API_PictureType, API_PrimPict
- picture : API_Element
- picturesInTIFF : API_SavePars_Archive
- pivotEdgeUnId : API_PivotPolyEdgeData
- pivotPolyEdges : API_ElementMemo
- pivotPolygon : API_PolyRoofData
- pixelSizeX : API_PictureType, API_PrimPict
- pixelSizeY : API_PictureType, API_PrimPict
- placeIndex : API_RailingFrameData
- placeInfo : API_GeoLocation
- placementMethod : API_CurtainWallType
- placeUnderEnabled : API_DimensionType
- plane : API_PolygonExt, API_ShellContourData
- plane1 : API_RuledShellData
- plane2 : API_RuledShellData
- planeCoord : API_GetPointType
- planeMatrix : API_CurtainWallType
- planeNormal : API_GetLineType, API_GetPointType, API_GetPolyType
- planeOffset : API_CurtainWallType
- planeSurface : API_AnalyticalSurface
- platformSign : API_HotlinkUserData, API_ModulData, API_UserData
- pline : API_PrimElement
- point : API_PrimElement
- pointOnCursor : API_CursorSet
- poly : API_ChangeMarkerType, API_DetailType, API_DrawingType, API_HatchType, API_InteriorElevationType, API_MeshType, API_PlaneRoofData, API_PolyLineType, API_PrimElement, API_ShellContourData, API_SlabType, API_WallType, API_ZoneType
- polyCanChange : API_WallType
- polyCoords : API_TestSplineFit
- polygon : API_CurtainWallType, API_CWContourData, API_PolygonExt, API_ShapePrimsParams, API_StairBoundaryData, API_StairPolylineData
- polygonData : API_PolygonExt
- polyLine : API_Element
- polylineWas : API_GetPolyType
- polyZCoords : API_ElementMemo
- popupText : API_AttributeManagerFormat
- popUpText : API_PublishFormatData
- pos : API_AngleDimensionType, API_ChangeMarkerType, API_DetailType, API_DimElem, API_DrawingType, API_GetArcType, API_GetLineType, API_GetPointType, API_HotspotType, API_NoteType, API_ObjectType, API_PerspPars, API_TabType, API_ZoneType
- pos3D : API_DimElem
- position : API_CWFrameQuantity, API_PrintStampType, API_RailingHorizontalPosData
- possibleEnumValues : API_PropertyDefinition
- posSign : API_PlaneRoofData
- postNum : API_RailingInnerPostType
- postOffset : API_RailingNodeType
- posx : API_LghtType
- posy : API_LghtType
- posz : API_LghtType
- prefix : API_LayoutBook, API_RadialDimensionType
- prefixUStr : API_RadialDimensionType
- prevCam : API_PerspCamPars
- previewMode : API_DrawingTitle
- primitiveType : API_IFCPropertyAnyValue
- printAlignment : API_PrintPars
- printArea : API_PrintPars
- printGhost : API_PrintPars
- profile : API_Attribute
- profile_vectorImageItems : API_AttributeDefExt
- profile_vectorImageParameterNames : API_AttributeDefExt
- profileAngle : API_BeamType
- profileAttr : API_AssemblySegmentData, API_WallType
- profileAttrIndex : API_AnalyticalCrossSection
- profileImage : API_AnalyticalCrossSection
- profileParameters : API_AnalyticalCrossSection
- profileType : API_AssemblySegmentData, API_WallType
- progressSounds : API_ImagingAndCalcPrefs
- projectedArea : API_CompositeQuantity, API_MeshQuantity
- projectionSetting : API_DocumentFrom3DType
- projectName : API_ProjectInfo, API_ProjectNoteInfo
- projectPath : API_ProjectInfo
- projectStatus : API_ProjectNoteInfo
- projMod : API_AxonoPars
- prompt : API_GetArcType, API_GetLineType, API_GetPointType, API_GetPolyType
- propCriteria : API_ObjectSettingsPars
- properties : API_Favorite
- propertiesOn : API_SavePars_Archive, API_SavePars_PlanDump
- propertyDescription : API_IFCPropertyHead
- propertyExpressions : API_PropertyDefaultValue
- propertyName : API_IFCPropertyHead, API_PropertyObjectParams
- propertySetName : API_IFCPropertyHead
- propertyType : API_ConditionalElementRule, API_IFCPropertyHead
- propertyUnID : API_PropertyObjectParams
- propIndivLibInd : API_ObjectSettingsPars
- proportional : API_RendImage
- pushCheckAppearance : API_AttributeFolderPickerParams, API_AttributePickerParams
- pushNeighborEnabled : API_DimensionType