Archicad 28 C++ API
|
Describes the different calculated values for curtain walls. More...
#include <APIdefs_Elements.h>
Public Attributes | |
double | framesLength |
Sum of all contained frame's length. | |
double | contourFramesLength |
Sum of the lengths of contour frames. | |
double | mainaxisFramesLength |
Sum of the lengths of the frames belong to the main axis (vertical) | |
double | secaxisFramesLength |
Sum of the lengths of the frames belong to the secondary axis (horizontal) | |
double | customFramesLength |
Sum of the lengths of the custom frames. (custom means in this case: diagonal frame inside the cell) | |
double | panelsSurface |
Sum of all contained panel's surface. Equal to the sum of panelsSurfaceN, panelsSurfaceS... and equal to the sum of surface values in the API_CWPanelQuantity structure. | |
double | panelsSurfaceN |
Sum of those panel's surface wich normal vector points to north. | |
double | panelsSurfaceS |
Sum of those panel's surface wich normal vector points to south. | |
double | panelsSurfaceE |
Sum of those panel's surface wich normal vector points to east. | |
double | panelsSurfaceW |
Sum of those panel's surface wich normal vector points to west. | |
double | panelsSurfaceNE |
Sum of those panel's surface wich normal vector points to north-east. | |
double | panelsSurfaceNW |
Sum of those panel's surface wich normal vector points to north-west. | |
double | panelsSurfaceSE |
Sum of those panel's surface wich normal vector points to south-east. | |
double | panelsSurfaceSW |
Sum of those panel's surface wich normal vector points to south-west. | |
double | contourSurface |
Surface bordered by contour. | |
double | boundarySurface |
Surface bordered by boundary frames. | |
double | length |
Length of the curtain wall. | |
double | height |
Height of the curtain wall. | |
double | slantAngle |
Slant angle of curtain wall. | |
UInt32 | numOfPanels |
The number of panels belong to the Curtain Wall. | |
Describes the different calculated values for curtain walls.