►NACAPI | |
►NCutaway | |
►Nv1 | |
CAPI_CutPolygonInfo | Information regarding cut polygons |
CCuttingPlane | CuttingPlane if the representation of the cutting plane settings |
►NDesignOptions | |
►Nv1 | |
CDesignOptionCombination | A class that represents the design option combination of the view settings |
►CDesignOptionCombinationViewSettings | A class that represents the design option combination settings of a view |
CCustom | A type of combination that the user has modified, but did not give an explicit name |
CMainModelOnly | A type of combination that has no design option connected to it, and only shows the main model |
CMissing | A type of combination that does not exist, and was previously deleted |
CStandard | A type of combination for which the user has selected a specific set of design options |
CDesignOptionManager | A class that contains design option related functions |
►NImpl | |
►Nv1 | |
CAbstractFactory | AbstractFactory is responsible for creating the implementation. You can make your own factory to use it in unit tests |
CFactoryRegistry | FactoryRegistry own the registered factory. Only one factory can be registered at the same time. Use this to register your mock factory when you're unit testing your code |
CObjectImpl | ObjectImpl is the base class for all the implementation classes |
►NKeynote | |
►Nv1 | |
CKeynoteFolder | A class that represents a folder in the keynote tree structure |
CKeynoteItem | A class that represents an item in the keynote tree structure |
CKeynoteManager | A class that contains keynote related functions |
►NLibrary | |
►Nv1 | |
CGSMObject | GSMObject is the representation of a loaded .gsm file |
CGSMSectionData | Raw GSMObject Section representation |
CLibPart | LibPart is the representation of a file-like item in a Library (.gsm, .png, .lis, etc..) |
CLibrary | Library is the representation of an item in the library list of an ArchiCAD project |
CLibraryManager | LibraryManager is the central point of the Library and the LibPart management |
CLibraryTreePath | Library tree location (E.g. folder, Library Part) |
►NLicenseInfo | |
►NImpl | |
CProductVersionInfoImplBase | Constructs an object of the ObjectImpl class |
►Nv1 | |
CLicenseInfoManager | LicenseInfoManager is the entry point of the license or product-related informations |
CProductVersionInfo | ProductVersionInfo is the central point of the product-related informations |
►NMEP | |
►NAdapter | |
CUniqueID | It is a helper class that converts a simple GS::Guid or API_Guid into an MEP::UniqueID |
►Nv1 | |
CAccessory | The Accessory is a complex element with two ports on a single axis |
CAccessoryDefault | The AccessoryDefault contains the necessary non-geometric data for creating an Accessory element |
CAccessoryUIManager | The AccessoryUIManager contains UI-related services for an Accessory |
CBend | The Bend can connect two straight RoutingSegments with the same dimensions but different directions |
CBendDefault | The BendDefault contains the necessary non-geometric data for modifying a Bend |
CBendUIManager | The BendUIManager contains UI-related services for a Bend |
CBranch | A branch is a specific type of fitting that acts as an outlet from a large pipe to a smaller pipe or one of equal size |
CBranchDefault | |
CBranchUIManager | The BranchUIManager contains UI-related services for a Branch |
CCableCarrierPort | The CableCarrierPort represents a connection point of a cable carrier |
CCableCarrierPortDefault | Through this CableCarrierPortDefault you can access and configure the CableCarrierPorts of MEPElementDefaults before placement |
CCableCarrierSegmentPreferenceTable | The CableCarrierSegmentPreferenceTable represents a named entity, that contains rows that consists of a size and a description. The rows have to be unique by value and are always in ascending order |
CCableCarrierSegmentPreferenceTableContainer | The CableCarrierSegmentPreferenceTableContainer can contain several PreferenceTableBase associated with cable carriers |
CDistributionSystem | A helper object representing a "distribution system", which is a set of MEP elements sharing the same system category index and MEP domain. (E.g. "hot water pipes" or "cold air ducts") |
CDistributionSystemsGraph | A graph data structure to display MEP distribution systems data |
CDistributionSystemsGraphTreeNode | A structural helper class used when iterating through a DistributionSystem in the DistributionSystemsGraph as a tree |
CDuctBranchPreferenceTable | The DuctBranchPreferenceTable contains cross section and geometry related information for Duct branches |
CDuctBranchPreferenceTableContainer | The DuctBranchPreferenceTableContainer can contain several DuctBranchPreferenceTables |
CDuctCircularSegmentPreferenceTable | The DuctCircularSegmentPreferenceTable contains cross section related information for Circular Duct routing segments |
CDuctElbowPreferenceTable | The DuctElbowPreferenceTable contains cross section related information for Duct elbows |
CDuctElbowPreferenceTableContainer | The DuctElbowPreferenceTableContainer can contain several DuctElbowPreferenceTables |
CDuctRectangularSegmentPreferenceTable | The DuctRectangularSegmentPreferenceTable represents a named entity, that contains rows that consists of a size and a description. The rows have to be unique by value and are always in ascending order |
CDuctReferenceSet | The DuctReferenceSet contains referenceIds that are used in DuctCircularSegmentPreferenceTable and DuctCircularElbowPreferenceTable |
CDuctSegmentPreferenceTableContainer | The DuctSegmentPreferenceTableContainer can contain several PreferenceTableBase associated with ventilation |
CElement | The Element represents an instantiable ElementBase |
CElementBase | |
CElementDefault | The ElementDefault contains the necessary non-geometric data for creating a MEP element |
CElementUIManager | The ElementUIManager contains UI-related services for an Element |
CEquipment | The Equipment is a complex element with more than two ports |
CEquipmentDefault | The EquipmentDefault contains the necessary non-geometric data for creating an Equipment element |
CEquipmentUIManager | The EquipmentUIManager contains UI-related services for an Equipment |
CFitting | A fitting is used in distribution systems to connect straight sections of pipes and ducts, adapting to different sizes or shapes |
CFittingDefault | The FittingDefault contains the necessary non-geometric data for creating a Fitting element |
CFittingUIManager | The FittingUIManager contains UI-related services for a Fitting |
CFlexibleSegment | In contrast to rigid segments flexible duct is not a connection of multiple elements (straight segments and bends), instead a type of ducting pipe that could easily be bent in different angles. Since Archicad 28 there is a flexible pipe as well for liquids. FlexibleSegment either has a spline geometry defined by control points, or a polyline geometry, which is defined by alternating straight line parts and spline parts. Line parts are defined by their starting and ending coordinates, while spline parts are defined by control points. These alterning segments must start where the previous one ends. Polyline FlexibleSegemnts are only supported in the Piping domain. In the Ventilation domain FlexibleSegments can only be splines |
CFlexibleSegmentDefault | The FlexibleSegmentDefault contains the necessary non-geometric data for creating a FlexibleSegment element |
CFlexibleSegmentUIManager | The FlexibleSegmentUIManager contains UI-related services for a FlexibleSegment |
CGraphCalculationInterface | A class to communicate between registered calculating addons and those using the calculations |
CICalculationResultColumn | Formatting for calculated values |
CModifiableElement | The Modifiable Element represents an instantiable ModifiableElementBase |
CModifiableElementBase | The ModifiableElementBase contains the available modifying actions for ElementBase |
CPipeBranchPreferenceTable | The PipeBranchPreferenceTable contains cross section and geometry related information for Pipe branches |
CPipeBranchPreferenceTableContainer | The PipeBranchPreferenceTableContainer can contain several PipeBranchPreferenceTables |
CPipeElbowPreferenceTable | The PipeElbowPreferenceTable contains cross section related information for Pipe elbows |
CPipeElbowPreferenceTableContainer | The PipeElbowPreferenceTableContainer can contain several PipeElbowPreferenceTables |
CPipeReferenceSet | The PipeReferenceSet contains referenceIds that are used in PipeSegmentPreferenceTable and PipeElbowPreferenceTable |
CPipeSegmentPreferenceTable | The PipeSegmentPreferenceTable contains cross section related information for Pipe routing segments |
CPipeSegmentPreferenceTableContainer | The PipeSegmentPreferenceTableContainer can contain several PreferenceTableBase associated with piping |
CPipingPort | The PipingPort represents a connection point of a pipe segment |
CPipingPortDefault | Through this PipingPortDefault you can access and configure the PipingPorts of MEPElementDefaults before placement |
CPort | The Port represents an instantiable PortBase. Through this object you can reference to the three domain's ports in a common way |
CPortBase | The Port is associated to an element and it represents a point between elements |
CPortDefaultBase | Through this PortDefault you can access and configure the Ports of MEPElementDefaults before placement |
CPreferenceTableContainerBase | The PreferenceTableContainerBase contains PreferenceTables, and you can Add/Get/Delete them |
CReferenceSetBase | The ReferenceSetBase represents a named table, and it contains referenceIds which are used as keys in the PreferenceTables. By default, Archicad will provide you the DN referenceSet, but you can choose your own by renaming it and populate it with your desired values |
CRigidSegment | The RigidSegment is placed in RoutingSegments |
CRigidSegmentDefault | The RigidSegmentDefault contains the necessary non-geometric data for creating a RigidSegment element |
CRigidSegmentUIManager | The RigidSegmentUIManager contains UI-related services for a RigidSegment |
CRoutingElement | The RoutingElement can contain Routing Segments and Routing Nodes |
CRoutingElementDefault | The RoutingElementDefault contains the necessary non-geometric data for creating a Routing element |
CRoutingElementUIManager | The RoutingElementUIManager contains UI-related services for a Routing element |
CRoutingNode | The RoutingNode can contain Bend and Transition elements |
CRoutingNodeDefault | The RoutingNodeDefault contains the necessary non-geometric data for creating and modifying a Routing Node |
CRoutingNodeUIManager | The RoutingNodeUIManager contains UI-related services for a RoutingNode |
CRoutingSegment | The RoutingSegment can contain Rigid Segment elements |
CRoutingSegmentDefault | The RoutingSegmentDefault contains the necessary non-geometric data for creating and modifying a Routing Segment |
CRoutingSegmentUIManager | The RoutingSegmentUIManager contains UI-related services for a RoutingSegment |
CTakeOff | The Take-off is a simple element with two ports on a single axis |
CTakeOffDefault | The TakeOffDefault contains the necessary non-geometric data for creating a Take-off element |
CTakeOffUIManager | The TakeOffUIManager contains UI-related services for an TakeOff |
CTerminal | The Terminal is a complex element with a single port |
CTerminalDefault | The TerminalDefault contains the necessary non-geometric data for creating a Terminal element |
CTerminalUIManager | The TerminalUIManager contains UI-related services for a Terminal |
CTransition | The Transition is an element that connects two different Routing Segments |
CTransitionDefault | The TransitionDefault contains the necessary non-geometric data for creating and modifying a Transition |
CTransitionUIManager | The TransitionUIManager contains UI-related services for a Transition |
CTypedCalculationResultColumn | Template typed version of the ICalculationResultColumn interface |
CVentilationPort | The VentilationPort represents a connection point of a duct |
CVentilationPortDefault | Through this VentilationPortDefault you can access and configure the VentilationPorts of MEPElementDefaults before placement |
CFlexibleSegmentPolylineLinePart | Defines a single line segment of a polyline FlexibleSegment |
CFlexibleSegmentPolylineSplinePart | Defines a single spline segment of a polyline FlexibleSegment |
COrientation | Defines the orientation with the help of a direction and rotation vector |
CRouteConnectionResult | Defines the changes regarding Ids after a RoutingElement-RoutingElement connection |
CRoutingSegmentCircularCrossSectionData | Defines the necessary data for placing CircularRoutingSegments of a RoutingElement |
CRoutingSegmentRectangularCrossSectionData | Defines the necessary data for placing RectangularRoutingSegments of a RoutingElement |
CUniqueID | The MEP unique identifier |
►NModelViews | |
►Nv1 | |
CView | A class that represents an Archicad navigator view |
►NTracking | |
►Nv1 | |
CTrackerManager | TrackerManager is a class to access the main tracker with |
►Nv1 | |
CElementBase | A base class for all elements |
CElementDefault | A base class for all element defaults |
CGSID | Serves as a means to query various unique identifiers of the logged-in user, facilitating stable user identification |
CInputHandler | A class to handle input related operations, like manipulating the input position and starting an input |
CObject | A base class for all ACAPI objects. Purely technical |
CUniqueID | A unique identifier for API objects. It contains the GUID of the element and the Token of the AddOn which instantiated the element |
CZoneBoundary | Represents a boundary between a Zone and another element. A boundary is the intersection of the coplanar surfaces of the Zone body and the boundary element. The surface will be split into multiple boundaries if it is connected to multiple Zones, one boundary for each Zone. A boundary can be either internal or external. An internal boundary is between two Zones, otherwise it is external |
CZoneBoundaryQuery | This class can be used to query the boundaries of Zones. Before use an Update must be called on it |
CZoneLabelingSettings | A class that contains functions related to zone labeling by favorite |
CAPI_IKeynoteEventNotifier | Defining an interface for a class that will be used to notify keynote event handlers |
CAPI_IKeynoteFolderEventHandler | The base class you need to inherit from in case you want to handle keynote folder events |
CAPI_IKeynoteItemEventHandler | The base class you need to inherit from in case you want to handle keynote item events |
CError | Error type for ACAPI::Result containing an error message and an error code |
CModifierBase | Base class of every Modifier classes used in ExecuteUndoableScope/ExecuteNotUndoableScope/CallDefaultModifier function |
CResult | Result is the standard return type of API functions |
►NGeometry | |
CGJKResult | |
►NIFCAPI | |
►Nv1 | |
CAssignments | Represents the persistent Assignment Tree in IFC |
CAttribute | Represents an IFC Attribute |
CClassification | Represents an IfcClassification |
CClassificationReference | Represents an IfcClassificationReference |
CHookAssignments | Class to set up an assignment structure for the assignments export hook |
CHookManager | To register an add-on for IFC hook callbacks, where one can provide their own data to the IFC export |
CObjectAccessor | To handle IFC objects, identifications and types |
CObjectID | Identifies an IFC entity (e.g: IfcBuildingStorey, IfcBeam, IfcZone, etc.) |
CProperty | Represents an IfcProperty |
CPropertyAccessor | To access IFC attributes, properties and classification references |
CPropertyBoundedValue | Represents an IfcPropertyBoundedValue |
CPropertyBuilder | To create IFC attribute, property or classification reference |
CPropertyEnumeratedValue | Represents an IfcPropertyEnumeratedValue |
CPropertyListValue | Represents an IfcPropertyListValue |
CPropertySingleValue | Represents an IfcPropertySingleValue |
CPropertyTableValue | Represents an IfcPropertyTableValue |
CValue | Represent an IFC value |
►Nstd | |
Chash< API_ElemType > | Std::hash specialization for API_ElemType |
►NTracking | |
►CTracker | Class for managing one specific tracker and its fields |
CHintGuard | Helper guard class to specify a hint what to do when the editing of a field needs to be ended and possibly the reason for ending it |
CInEditKeyboardHandler | Class to derive from, when creating custom keyboard handlers for the tracker's edit mode |
CRunningModeKeyboardHandler | Class to derive from, when creating custom keyboard handlers for the tracker's running mode |
CAPI_3D_Head | Common header for the 3D components |
CAPI_3DCutPlanesInfo | Data of the "3D Cutting Planes..." dialog |
CAPI_3DCutShapeType | Shape of the 3D cutting plane |
CAPI_3DFilterAndCutSettings | Parameters of the 'Filter and Cut Elements in 3D' dialog |
CAPI_3DProjectionInfo | 3D projection setting parameters |
CAPI_3DStyle | 3D Style parameters |
CAPI_3DWindowInfo | 3D Window setting parameters |
CAPI_ActTranPars | Structure for retrieving the transformation data of the actual editing operation |
CAPI_AddOnCommand | Base class for the Add-On commands |
CAPI_AddOnInfo | Textual description of the add-on |
CAPI_AddonObject | Control information of a custom data stored into the project database |
CAPI_AddParType | Describes a parameter of a Library Part |
CAPI_AM_VisibilitySettings | Describes the Analytical Model Visiblity Settings |
CAPI_AMPartRefCustomVertexData | Describes a vertex when the analytical member part has custom vertex type |
CAPI_AMPartRefRatioEdgeData | Describes the ratios when the analytical member part has ratio edge type |
CAPI_AnalyticalCrossSection | Describes or references an Structural Analytical Model Cross Section for Curve Members |
CAPI_AnalyticalCurve | Describes an Structural Analytical Model Curve that is either a line segment between two Structural Analytical Model Nodes, or an arc segment with a specified intermediate point |
CAPI_AnalyticalCurveMember | Describes an Structural Analytical Model Curve Member |
CAPI_AnalyticalCylinderSurface | TBD |
CAPI_AnalyticalEdgeLoad_Settings | Describes the Structural Analytical Model Analytical Edge Load settings |
CAPI_AnalyticalEdgeLoadType | Describes a Structural Analytical Model Member Edge Load |
CAPI_AnalyticalElemPartId | Describes the guid, contour and edge/vertex id triplet that is used for creating the API_ExportIdMappingType |
CAPI_AnalyticalLink_RigidSettings | Describes the rigidity settings on both sides of the Structural Analytical Model Analytical Link element |
CAPI_AnalyticalLink_Rotation | Contains the Structural Analytical Model Analytical Link Rotation values |
CAPI_AnalyticalLink_Settings | Describes the Structural Analytical Model Analytical Link settings |
CAPI_AnalyticalLink_SpringSettings | Describes the spring settings of the Structural Analytical Model Analytical Link element |
CAPI_AnalyticalLink_Translation | Describe the translation of an analitycal link |
CAPI_AnalyticalLinkGeometry | Describes a Structural Analytical Model Analytical Link Geometry |
CAPI_AnalyticalLinkType | Describes a Structural Analytical Model Analytical Link |
CAPI_AnalyticalLoadCase | Describes a Structural Analytical Load Case |
CAPI_AnalyticalLoadCombination | Describes a Structural Analytical Load Combination |
CAPI_AnalyticalLoadFactor | Describes how a Load Case belongs to a Load Combination |
CAPI_AnalyticalLoadGroup | Describes a Structural Analytical Load Group |
CAPI_AnalyticalMemberPartRef | Describes a Structural Analytical Model Analytical Member part |
CAPI_AnalyticalModelVariation | Describes the Model Variation that is used for creating the Structural Analytical Model |
CAPI_AnalyticalNode | Describes an Structural Analytical Node |
CAPI_AnalyticalPlaneSurface | TBD |
CAPI_AnalyticalPointLoad_Settings | Describes the Structural Analytical Model Analytical Point Load settings |
CAPI_AnalyticalPointLoadGeometry | Describes a Structural Analytical Model Analytical Point Load Geometry |
CAPI_AnalyticalPointLoadType | Describes a Structural Analytical Model Member Point Load |
CAPI_AnalyticalReleaseDescription | Contains the Structural Analytical Model Analytical Member Release values |
CAPI_AnalyticalReleaseType | Describes a Structural Analytical Model Member release |
CAPI_AnalyticalSupport_Settings | Describes the Structural Analytical Model Analytical Support settings |
CAPI_AnalyticalSupport_SupportValues | Contains the Structural Analytical Model Analytical Support values |
CAPI_AnalyticalSupportGeometry | Describes a Structural Analytical Model Analytical Support Geometry |
CAPI_AnalyticalSupportType | Describes a Structural Analytical Model Member Support |
CAPI_AnalyticalSurface | Describes the Structural Analytical Model Surface of a Structural Analytical Model Surface Member |
CAPI_AnalyticalSurfaceLoad_Settings | Describes the Structural Analytical Model Analytical Surface Load settings |
CAPI_AnalyticalSurfaceLoadType | Describes a Structural Analytical Model Member Surface Load |
CAPI_AnalyticalSurfaceMember | Describes a Structural Analytical Model Surface Member |
CAPI_AnalyticalVaryingSegment | Describes a Structural Analytical Model Varying Segment for Curve Members |
CAPI_AngleDimensionType | Represents an angle dimension |
CAPI_AngleDimFormat | The representation of the angle dimensioning on the Preferences / Dimensioning tab page |
CAPI_ArcType | Represents an elliptical or circular arc |
CAPI_AreaDimFormat | The representation of the area dimensioning on the Preferences / Dimensioning tab page |
CAPI_ArrowData | Describes the arrows at line ends |
CAPI_AssemblySegmentCutData | Represents a cut on segment |
CAPI_AssemblySegmentData | Represents an general segment |
CAPI_AssemblySegmentProfileData | Represents an segment of the beam element |
CAPI_AssemblySegmentSchemeData | Represents a segment scheme |
CAPI_Attr_Head | Contains common information related to all attribute types |
CAPI_Attribute | Describes the different attributes |
CAPI_AttributeDef | Describes the extended information for different attributes |
CAPI_AttributeDefExt | Describes the extended information for different attributes |
CAPI_AttributeFolder | An attribute folder |
CAPI_AttributeFolderContent | Content of an attribute folder. Contains direct subfolders and attributes |
CAPI_AttributeFolderPicker | Describes an attribute folder picker created in ACAPI_Attribute_CreateAttributeFolderPicker, with getter and setter for the selected attribute folder and the hanlder of push check click event |
CAPI_AttributeFolderPickerParams | Describes the type and the push check for creating an attribute folder picker in ACAPI_Attribute_CreateAttributeFolderPicker |
CAPI_AttributeIndex | Index reference to an attribute |
CAPI_AttributeManagerFormat | Represents the data of an attribute manager format |
CAPI_AttributePicker | Describes an attribute picker created in ACAPI_Dialog_CreateAttributePicker, with getter and setter for the selected attribute and the hanlder of push check click event |
CAPI_AttributePickerParams | Describes the type and the push check for creating an attribute picker in ACAPI_Dialog_CreateAttributePicker |
CAPI_AxonoPars | Parallel projection parameters |
CAPI_Base | The base of a non-static linear, angle or radial dimension element |
CAPI_Beam_Hole | Describes a beam hole |
CAPI_BeamPart | Section of a beam that crosses the room |
CAPI_BeamQuantity | Describes the different calculated values for beams |
CAPI_BeamRelation | Structure for retrieving connection data of a beam |
CAPI_BeamSegmentQuantity | Describes the different calculated values for beam segments |
CAPI_BeamSegmentRelation | Structure for retrieving connection data of a beam segment |
CAPI_BeamSegmentType | Represents an segment of the beam element |
CAPI_BeamType | Represents a beam element |
CAPI_BodyType | Representation of a 3D body |
CAPI_Box | Rectangular region of the model |
CAPI_Box3D | Rectangular region of the model with Z extent |
CAPI_BuildingMaterialType | Building Material type attribute representation |
CAPI_CalcAngleFormat | The API_CalcUnitPrefs structure contains this structure |
CAPI_CalcAreaFormat | The API_CalcUnitPrefs structure contains this structure |
CAPI_CalcLengthFormat | The API_CalcUnitPrefs structure contains this structure |
CAPI_CalcRulesPrefs | The representation of the Calculation Rules on the Preferences / Calculation Units Rules tab page |
CAPI_CalcUnitPrefs | The representation of the Project Preferences / Calculation Units Rules tab page |
CAPI_CalcVolumeFormat | The API_CalcUnitPrefs structure contains this structure |
CAPI_CameraType | Represents a single camera |
CAPI_CamSetType | Represents a camera set |
CAPI_ChangeMarkerType | Represents a ChangeMarker (a placeable element, not to be confused with the Change from the Change Manager palette) |
CAPI_ChangeParamType | Parameters to change a value in a Library Part parameter list |
CAPI_ClassificationItem | Specifies a classification item |
CAPI_ClassificationSystem | Specifies a classification system |
CAPI_ClipTran | Defines a transformation for the clipping |
CAPI_CollisionDetectionSettings | Collision detection settings used by ACAPI_Element_GetCollisions |
CAPI_CollisionElem | A container for storing a collision element created by ACAPI_Element_GetCollisions |
CAPI_ColumnQuantity | Describes the different calculated values for columns |
CAPI_ColumnSegmentQuantity | Describes the different calculated values for column segments |
CAPI_ColumnSegmentType | Represents an segment of the column element |
CAPI_ColumnType | Represents a column element |
CAPI_Component3D | General representation of a 3D component |
CAPI_ComponentID | Identifies a component |
CAPI_CompositeId | Identifies the composite skin and sub-element |
CAPI_CompositeQuantity | Describes the different calculated values for skins of composite or complex elements |
CAPI_CompWallType | Composite fill attribute representation |
CAPI_ConditionalElementRule | The representation of a conditional element rule on the Preferences / Calculation Rules tab page |
CAPI_ConnectionGuidItem | Represents a wall or beam connection |
CAPI_ConstraintPars | Parameters of the drawing constraint |
CAPI_ContentPars | It is used at the ACAPI_Element_Change goodie function |
CAPI_ContourEdgeData | Parameters of a shell contour edge |
CAPI_Coord | A pair of Cartesian (real) coordinates |
CAPI_Coord3D | Real (Cartesian) 3D coordinates of a three-dimensional space |
CAPI_CoordinateSystem | Describes a coordinate system |
CAPI_CoverFillTransformation | Fill orientation and distortion parameters |
CAPI_CursorSet | Cursor set definition for a user input |
CAPI_CurtainWallModelViewOptions | Represents the model view options of Curtain Walls made with the Curtain Wall Tool. The entire structure is Archicad only |
CAPI_CurtainWallQuantity | Describes the different calculated values for curtain walls |
CAPI_CurtainWallType | Represents a Curtain Wall element |
CAPI_CutPlaneType | Represents a section element |
CAPI_CWAccessoryQuantity | Describes the different calculated values for curtain wall accessories |
CAPI_CWAccessoryType | Represents a curtain wall accessory element |
CAPI_CWallComponent | Describes the simple fills contained in composite structures |
CAPI_CWallLineComponent | Describes the lines separate the simple fills contained in composite structures |
CAPI_CWallPanel | A primitive triangle |
CAPI_CWContourData | Represents a curtain wall contour type element |
CAPI_CWFrameQuantity | Describes the different calculated values for curtain wall frames |
CAPI_CWFrameType | Represents a Curtain Wall Frame element |
CAPI_CWJunctionQuantity | Describes the different calculated values for curtain wall junctions |
CAPI_CWJunctionType | Represents a curtain wall junction element |
CAPI_CWPanelQuantity | Describes the different calculated values for curtain wall panels |
CAPI_CWPanelRelation | Structure for retrieving connection data of a curtain wall panel, skylight, window or a door element |
CAPI_CWPanelType | Represents a Curtain Wall Panel element |
CAPI_CWSegmentPatternCellData | Represents a curtain wall segment cell |
CAPI_CWSegmentPatternData | Represents the horizontal (primary) or vertical (secondary) pattern of a Curtain Wall segment |
CAPI_CWSegmentType | Represents a curtain wall segment element |
CAPI_DailyProfile | Describes a daily profile contained in Operation Profile |
CAPI_DailyProfileUsage | Describes a daily profile usage contained in Operation Profile |
CAPI_DashItems | Describes one segment of a dashed line |
CAPI_DatabaseUnId | Identification parameters of a Section, Detail, Interior Elevation, Worksheet, Master Layout, Layout, and 3D Document window or window related database |
CAPI_DescriptorRefType | The descriptor reference record |
CAPI_DescriptorType | Description of a descriptor |
CAPI_DetailType | Represents a detail/worksheet (detail/worksheet mark) |
CAPI_DimBase | Describes the base element for dimensioning |
CAPI_DimElem | Describes a dimension element |
CAPI_DimensionPrefs | The representation of the Project Preferences / Dimensions tab page |
CAPI_DimensionStandards_Head | Contains common information related to dimension preference types |
CAPI_DimensionStandardsType | Representation of the dimension preference |
CAPI_DimensionType | Describes a (linear) dimension |
CAPI_DocumentFrom3DDefaults | Default settings of 3D document |
CAPI_DocumentFrom3DType | Represents a 3D Document |
CAPI_DrawingLinkInfo | Parameters of a drawing link |
CAPI_DrawingTitle | Specifies the drawing's title object |
CAPI_DrawingType | Represents a drawing element |
CAPI_EdgeLoadCustomData | Describes a Structural Analytical Model Analytical Edge Load Geometry |
CAPI_EdgeTrim | Describes the parameters of a roof or slab edge. In previous API versions this structure used to be called API_RoofSide |
CAPI_EdgeType | Representation of a 3D edge |
CAPI_EditPars | Transformation parameters for elements |
CAPI_Elem_Head | General element header for element types |
CAPI_ElemCategory | Element category structure |
CAPI_ElemCategoryValue | Element category value structure |
CAPI_ElemComponentID | Identifies a component of an element |
CAPI_ElemDifference | Common structure for the element difference generator components |
CAPI_ElemDifferenceGeneratorState | Common structure for the element difference generator components |
CAPI_Element | A union collecting all known element types |
CAPI_ElementDecomposerInterface | Interface class for the element decomposition process |
CAPI_ElementMemo | Describes the variable length additional data of elements |
CAPI_ElementQuantity | Describes the different calculated values |
CAPI_ElementQuantityMask | Describes the filter for the different calculated values for elements |
CAPI_ElemInfo3D | 3D data of an element |
CAPI_ElemPartCompositeQuantity | Describes the different calculated values for skins of composite or complex elements |
CAPI_ElemPartId | Identify a part of an element. It's valid for PolyRoof and Morph only |
CAPI_ElemPartQuantity | Describes the different calculated values for parts of an element |
CAPI_ElemPartSurfaceQuantity | Describes the different calculated values for surfaces of elements |
CAPI_ElemSearchPars | Structure to search for an element by coordinate |
CAPI_ElemType | The type of an element |
CAPI_ElemURLRef | URL reference to be stored into elements |
CAPI_EnvirParams | Describes the different parameters of the running environment |
CAPI_ESYMParams | Describes the current external symbol your add-on can work on |
CAPI_ExportIdMappingType | Describes the connection between the unsegmented surface member's and the created segment's edges and vertices |
CAPI_ExtendedPenType | Describes the optionally overridden pen used for hatches |
CAPI_ExternalElemType | A struct containing the header and data of an external element type (see API_AnalyticalLinkType) |
CAPI_ExtrudedShellData | This structure holds the Extruded Shell specific data of API_ShellType |
CAPI_Favorite | A container for Favorite entry settings |
CAPI_FileOpenPars | Parameters to open a new project file |
CAPI_FileSavePars | Parameters to save the current project file |
CAPI_FillLine | Describes the details of a vectorial fill |
CAPI_FilltypeType | Fill type attribute representation |
CAPI_FloorPlanCutDefinition | Parameters of the Floor Plan Cut Plane Settings dialog |
CAPI_Font_Head | Contains common information related to API_FontType |
CAPI_FontType | Contains common information related to a font |
CAPI_Gable | Defines a cutting plane applied to spatial elements |
CAPI_GDLModelViewOptions | Represents the GDL related model view options |
CAPI_GeoLocation | Geo Location data of the project |
CAPI_GeoReferenceData | Coordinate Reference System and Map Conversion parameters of the Geo Location of the project |
CAPI_Get3DComponentType | Parameters of the get component type in 3D operation |
CAPI_GetArcType | Parameters of the arc input operation |
CAPI_GetLineType | Parameters of the line input operation |
CAPI_GetParamsType | The changed parameter values of a Library Part |
CAPI_GetParamValuesType | The possible parameter values of a non-array Library Part parameter |
CAPI_GetPointType | Parameters of the point input operation |
CAPI_GetPolyType | Parameters of the polygon input operation |
CAPI_GhostRecord | Describes a tracing (ghost) database |
CAPI_GhostStoryType | Ghost Story settings |
CAPI_GridEdgeInfo | Contains extended information of a API_GridMeshEdge |
CAPI_GridMesh | Describes a Curtain Wall segment geometry |
CAPI_GridMeshEdge | Describes a Grid Mesh edge |
CAPI_GridMeshHead | General header for Grid Mesh type |
CAPI_GridMeshLine | Describes a grid line of the mesh |
CAPI_GridMeshPolygon | A 3D mesh polygon with four edge indices |
CAPI_GridMeshVertex | Describes a Grid Mesh vertex |
CAPI_GridType | The grid parameters |
CAPI_Guid | Represents a GS::Guid in the API layer |
CAPI_HatchOrientation | Fill orientation and distortion parameters |
CAPI_HatchQuantity | Describes the different calculated values for fills |
CAPI_HatchType | Represents a hatch element |
CAPI_HotlinkCacheGenerator | Base class for generating the updated content of a hotlink cache |
CAPI_HotlinkNode | Describes a hotlink node |
CAPI_HotlinkType | Represents a Hotlink Module type or XRef type hotlink instance element |
CAPI_HotlinkUserData | Hotlink user data |
CAPI_HotspotType | Represents a hotspot |
CAPI_HourlyProfile | Describes coverage of an hour of an Operation Profile |
CAPI_IACEventNotifier | Defining an interface for a class that will be used to notify event handlers |
CAPI_IAttributeEventHandler | Defining an interface for Attribute event handlers |
CAPI_IAttributeFolderEventHandler | Defining an interface for Attribute Folder event handlers |
CAPI_IClassificationItemEventHandler | The base class you need to inherit from in case you want to handle API_ClassificationItem events |
CAPI_IClassificationSystemEventHandler | The base class you need to inherit from in case you want to handle API_ClassificationSystem events |
CAPI_IDialogEventHandler | Defining an interface for Dialog event handlers |
CAPI_IEnableAllInfoDialogEventHandler | |
CAPI_IEventHandler | Defining an interface for all event handlers |
CAPI_IEventNotifier | Defining an interface for a class that will be used to notify all event handlers |
CAPI_IFCAttribute | IFC attribute structure |
CAPI_IFCClassification | IFC classification structure |
CAPI_IFCClassificationReference | IFC classificationreference structure |
CAPI_IFCProperty | IFC property container structure |
CAPI_IFCPropertyAnyValue | IFC property base value data container |
CAPI_IFCPropertyBoundedValue | IFC property with a lowerbound and an upperbound value |
CAPI_IFCPropertyEnumeratedValue | IFC property with a list of possible and selected value |
CAPI_IFCPropertyHead | IFC property header structure |
CAPI_IFCPropertyListValue | IFC property with a list of values |
CAPI_IFCPropertySingleValue | IFC property with a single value |
CAPI_IFCPropertyTableValue | IFC property with a list of value pairs |
CAPI_IFCPropertyValue | IFC property value data container |
CAPI_IFCRelationshipData | Contains IFC Entity relations which are specific for the IFC. The IFC Entities are represented by their GlobalId |
CAPI_IFCTranslatorIdentifier | IFC Translator Identifier |
CAPI_IGraphisoftIDEventHandler | |
CAPI_ImagingAndCalcPrefs | The representation of the Imaging and Calculation tab page of the Work Environment dialog |
CAPI_IMarqueeEventHandler | |
CAPI_ImportIdMappingType | Describes the connection between the (un)segmented surface segments and the created member's edges and vertices |
CAPI_InteriorElevationType | An iterior elevation element |
CAPI_InternalAnalyticalMemberPartId | Describes a Structural Analytical Model Analytical Member part |
CAPI_Interval | Describes an interval with handling possible periodicity |
CAPI_IObjectEventHandler | Defining an interface for Object event handlers |
CAPI_IOParams | Describes the file to work on in your callback procedure |
CAPI_IPropertyDefinitionEventHandler | The base class you need to inherit from in case you want to handle API_PropertyDefinition events |
CAPI_IPropertyGroupEventHandler | The base class you need to inherit from in case you want to handle API_PropertyGroup events |
CAPI_IWindowEventHandler | The base class you need to inherit from in case you want to handle window change events |
CAPI_KeyType | Description of a key |
CAPI_LabelType | Represents a textual or a symbol label |
CAPI_LayerCombType | Layer combination attribute representation |
CAPI_LayerStat | Describes one layer's characteristics in a layer combination |
CAPI_LayerType | Layer attribute representation |
CAPI_LayoutBook | Represents the Book settings |
CAPI_LayoutInfo | Properties of an Archicad Layout |
CAPI_LayoutsPrefs | The representation of the Layouts page of the Project Preferences |
CAPI_LegacyPrefs | The representation of the Preferences / Legacy tab page |
CAPI_LengthDimFormat | The representation of the linear, radial, level, elevation, door/window and parapet dimensioning on the Preferences / Dimensioning tab page |
CAPI_LevelDimensionType | Represents a level dimension |
CAPI_LghtType | Representation of a 3D light source |
CAPI_LibPart | Definition of a Library Part |
CAPI_LibPartDetails | Detail parameters of a Library Part |
CAPI_LibPartDoorWindowDetails | Library part's details of window and door. Used in API_LibPartDetails |
CAPI_LibPartObjectDetails | Library part's details of object, light, label and zone. Used in API_LibPartDetails |
CAPI_LibPartSection | Definition of a Library Part section |
CAPI_LibraryInfo | Describes the data of an active library of an Archicad project |
CAPI_LineItems | Describes the details of a symbol line |
CAPI_LineType | Represents a 2D line |
CAPI_LinetypeType | Line type attribute representation |
CAPI_LinkToSettings | Option for linking model elements to their home stories |
CAPI_LinkType | Describes a link for cameras |
CAPI_ListData | The representation of a listdata |
CAPI_ListData_Head | Contains common information related to all listing component types |
CAPI_ListDataSetType | Representation of a listdata set |
CAPI_ListVariant | A container for storing a list of values |
CAPI_LocalCoordsData | Dynamic array of API_LocalCoordsType items. This structure is used in API_RoofSegmentData |
CAPI_LocalCoordsType | Texture applying parameters. This structure is used in API_LocalCoordsData |
CAPI_MagicWandInfo | Curve tracing parameters |
CAPI_MarkerData | Describes the various parameters of dimension markers |
CAPI_MarkerLinkDataType | This type manifestates as a "linkedMarker" named variable in the detail/worksheet, section and elevation API types, and used to set the referring properties of the marker |
CAPI_MarkUpCommentType | Represents a comment attached to a Mark-Up entry |
CAPI_MarkUpType | Represents a Mark-Up entry |
CAPI_MarqueeFilter | Defines the filter for 3D filter and cut settings |
CAPI_MaterialType | Description of a surface material attribute |
CAPI_MDCLParameter | Parameter structure used for inter-addon communication |
CAPI_MenuItemRef | Reference to a menu item mounted by the API tool add-on |
CAPI_MenuParams | Describes the menu item that was chosen |
CAPI_MEPSystemType | MEP System attribute representation |
CAPI_MeshLevel | Defines the level lines of a mesh |
CAPI_MeshLevelCoord | Describes one coordinate of a mesh level line |
CAPI_MeshQuantity | Describes the different calculated values for meshes |
CAPI_MeshType | Represents a mesh |
CAPI_MimePicture | Structure for picture conversion using MIME identifier |
CAPI_MiscAppInfo | Miscellaneous information of the application |
CAPI_MiscPlotterInfo | Miscellaneous information of the selected plotter |
CAPI_MiscPrinterInfo | Miscellaneous information of the selected printer |
CAPI_ModelViewOptions | Represents the model view options |
CAPI_ModelViewOptions_Head | Contains common information related to API_ModelViewOptionsType types |
CAPI_ModelViewOptionsType | Representation of the model view options |
CAPI_ModulData | Control information of a custom data section saved into the project file |
CAPI_ModulID | Unique identifier of an add-on |
CAPI_MonolithPartsVisibilityData | Describes which types of monolith parts are visible |
CAPI_MonolithStairStructData | Represents the data of a monolithic Stair Structure element |
CAPI_MorphQuantity | Returns the morph quantity values |
CAPI_MorphType | Represents a morph element |
CAPI_NavigatorAddOnViewPointData | Describes a Navigator AddOn viewpoint root, group or leaf node |
CAPI_NavigatorItem | Represents a Project Navigator item |
CAPI_NavigatorSet | Parameters of a project Navigator Set |
CAPI_NavigatorView | Representation of a Navigator view item |
CAPI_Neig | Describes a neig point of an element |
CAPI_NewProjectPars | Parameters to open a new project |
CAPI_NewWindowPars | Parameters to open a new window |
CAPI_Niche | Structure describing a niche in a room |
CAPI_NoteType | Describes a general note, used in dimensioning and hatch text |
CAPI_NotifyElementType | Describes the element the notification is coming for, and the type of the notification |
CAPI_NotifyViewEventType | Describes the Project Navigator item the notification is coming for, and the type of the notification |
CAPI_NumberingGridLine | Represents a drawing numbering grid line of the layout |
CAPI_ObjectQuantity | Describes the different calculated values for objects |
CAPI_ObjectSettingsPars | Defines the parameters of the Object Settings dialog |
CAPI_ObjectType | Represents an object or a lamp, or a symbol label |
CAPI_Obsolete_ComponentRefType | The component reference record |
CAPI_Obsolete_ComponentType | Description of a component |
CAPI_OnScreenViewOptions | Representation of the display only options |
CAPI_OpeningBaseType | Represents the common part of window, door and skylight elements |
CAPI_OpeningCoverFillsParameters | Opening cover fills parameters |
CAPI_OpeningCutSurfacesParameters | Cut surface parameters |
CAPI_OpeningExtrusionGeometryData | Extrusion geometry parameters |
CAPI_OpeningExtrusionParameters | Opening extrusion parameters |
CAPI_OpeningFloorPlanParameters | Parameters of floor plan and section representation |
CAPI_OpeningOutlinesParameters | Opening outlines parameters |
CAPI_OpeningReferenceAxisParameters | Opening floor plan and section reference axis parameters |
CAPI_OpeningType | Represents an opening element |
CAPI_OpenLibPartInfo | The information of a library part required for opening the library part with ACAPI_LibraryManagement_OpenLibraryPart |
CAPI_OperationProfileType | An Energy Evaluation operation profile |
CAPI_OverriddenFillType | Describes the fill types to be overridden |
CAPI_OverriddenSurfaceType | Describes the surface types to be overridden |
CAPI_OverrideCombination | Represents a combination of override rules with a name |
CAPI_OverrideRule | Represents an override rule |
CAPI_OverrideRuleGroup | Represents a group of override rules with a name |
CAPI_OverrideRuleStyle | Specifies what, and how an API_OverrideRule should override |
CAPI_OverrideStyle | Specifies what is overridden and how, for an API_Element |
CAPI_ParagraphType | Describes a paragraph of a text |
CAPI_ParamOwnerType | Parameters to specify the target parameter list to change |
CAPI_PedgType | Representation of a 3D edge reference |
CAPI_Pen | Pen attribute representation |
CAPI_PenTableType | Pen table attribute |
CAPI_PersCamSetPars | Represents a perspective camera set |
CAPI_PerspCamPars | Parameters of a perspective camera |
CAPI_PerspPars | Perspective projection parameters |
CAPI_PetPaletteType | Parameters for performing user input with pet palette |
CAPI_PgonType | Representation of a 3D Polygon |
CAPI_PhotoRenderPars | Parameters for saving photo rendered picture into an image file |
CAPI_PictureHandle | Structure for picture conversion |
CAPI_PictureType | Represents a figure (picture) element |
CAPI_PivotPolyEdgeData | Complete polygon descriptor for polyroofs and shells. This structure is used in API_ElementMemo |
CAPI_PlaceInfo | The current location, date and sun parameters |
CAPI_Plane3D | Desribes a 3D plane |
CAPI_PlaneRoofData | This structure holds the Single-plane Roof specific data of API_RoofType |
CAPI_Point | Pixel data |
CAPI_PolyArc | Representation of an arc segment of a two dimensional polygon |
CAPI_Polygon | Representation of a two dimensional polygon |
CAPI_PolygonExt | Representation of a 2D polygon and the 3D transformation plane |
CAPI_PolyLineType | Represents a 2D polyline |
CAPI_PolyRoofData | This structure holds the Multi-plane Roof specific data of API_RoofType |
CAPI_Prim_Head | Header information for primitive elements |
CAPI_PrimArc | A primitive arc |
CAPI_PrimElement | A union containing all drawing primitives used with ACAPI_DrawingPrimitive_ShapePrims and ACAPI_LibraryPart_ShapePrims |
CAPI_PrimElemRef | Primitive element reference |
CAPI_PrimHatchBorder | Hatch border for primitive elements |
CAPI_PrimHotspot | A primitive hotspot |
CAPI_PrimLine | A primitive line |
CAPI_PrimPict | A picture inside a placed drawing |
CAPI_PrimPLine | A primitive polyline |
CAPI_PrimPoint | A primitive point |
CAPI_PrimPoly | A primitive polygon |
CAPI_PrimText | A primitive text |
CAPI_PrimTri | A primitive triangle |
CAPI_PrintPars | Printing parameters |
CAPI_PrintStampType | Printing header/footer parameters |
CAPI_ProfileAttrType | Attribute representing the custom profiles for walls, beams, and columns |
CAPI_ProjectInfo | Contains information about the current project |
CAPI_ProjectNoteInfo | Project note information parameters |
CAPI_Property | A container that can store different types of data |
CAPI_PropertyConversionUtilsInterface | |
CAPI_PropertyDefaultValue | A structure representing a property default value |
CAPI_PropertyDefinition | A structure representing a property definition |
CAPI_PropertyGroup | A structure representing a property group |
CAPI_PropertyObjectParams | Defines parameters for the property handler function |
CAPI_PropertyObjectRefType | The property object reference record |
CAPI_PropertyValue | A container for storing a property's value |
CAPI_PublishFormatData | Represents the data of a publisher format |
CAPI_PublishPars | Publishing parameters |
CAPI_Quantities | Describes the different calculated values for skins of composite or complex elements |
CAPI_QuantitiesMask | Describes the filter for the different calculated values for skins and elements |
CAPI_QuantityPar | Supplies extra information for some element quantity calculations |
CAPI_RadialDimensionType | Represents a radial dimension |
CAPI_RailingBalusterQuantity | Calculated values for the balusters |
CAPI_RailingBalusterSetType | Represents a Baluster Set element |
CAPI_RailingBalusterType | Represents a Baluster element |
CAPI_RailingDistributionData | Represents the distribution of some Railing subelements |
CAPI_RailingFinishType | Represents the finish of a Rail End element |
CAPI_RailingFrameData | Represents the boundaries of a Railing subelement |
CAPI_RailingHandrailConnectionQuantity | Calculated values for the handrail connection |
CAPI_RailingHandrailEndQuantity | Calculated values for the handrail end of the railing |
CAPI_RailingHandrailQuantity | Calculated values for a handrail |
CAPI_RailingHandrailType | Represents a Handrail element |
CAPI_RailingHorizontalPosData | Represents the horizontal alignment of a Railing subelement |
CAPI_RailingInnerPostQuantity | Calculated values for the railing inner posts |
CAPI_RailingInnerPostType | Represents an Inner Post element |
CAPI_RailingModelViewOptions | Represents the model view options of Railings made with Railing Tool. The entire structure is Archicad only |
CAPI_RailingNodeType | Represents a Railing Node element |
CAPI_RailingPanelQuantity | Calculated values for railing panels |
CAPI_RailingPanelType | Represents a Railing Panel element |
CAPI_RailingPatternType | Represents a Railing Pattern element |
CAPI_RailingPostQuantity | Calculated values for the railing posts |
CAPI_RailingPostType | Represents a Railing Post element |
CAPI_RailingQuantity | Calculated values for a railing |
CAPI_RailingRailConnectionQuantity | Calculated values for the rail connection |
CAPI_RailingRailConnectionType | Represents a connection between two Rail/Handrail/Toprail elements |
CAPI_RailingRailEndQuantity | Calculated values for the rail end of the railing |
CAPI_RailingRailEndType | Represents a Rail/Handrail/Toprail End element |
CAPI_RailingRailQuantity | Calculated values for the rails of the railing |
CAPI_RailingRailType | Represents a Rail element |
CAPI_RailingSegmentQuantity | Calculated values for the railing segments |
CAPI_RailingSegmentType | Represents a Railing Segment element |
CAPI_RailingToprailConnectionQuantity | Calculated values for the top rail connection |
CAPI_RailingToprailEndQuantity | Calculated values for the top rail end of the railing |
CAPI_RailingToprailQuantity | Calculated values for a top rail |
CAPI_RailingToprailType | Represents a Toprail element |
CAPI_RailingType | Represents a Railing element |
CAPI_RailingVerticalPosData | Represents the vertical position of a Railing subelement |
CAPI_Rect | Rectangle in pixel coordinates |
CAPI_RefLevelsPrefs | The representation of the Reference Levels on the Preferences / Working Units Levels tab page |
CAPI_Region | Polygonal or rectangular region of the model |
CAPI_RegularizedPoly | Structure for regularizing polygon or polyline |
CAPI_RendEffects | The representation of the Rendering Settings / Effects tab page |
CAPI_RendImage | The representation of the Rendering Settings / Size Background tab page |
CAPI_RevolvedShellData | This structure holds the Revolved Shell specific data of API_ShellType |
CAPI_RGBAColor | RGB color reference with transparency |
CAPI_RGBColor | RGB color reference |
CAPI_RoofLevelData | Defines a level of a polyroof plane. This structure is used in API_PolyRoofData |
CAPI_RoofQuantity | Gives the different calculated values for roofs |
CAPI_RoofRelation | Structure for retrieving connection data of a roof or a shell element |
CAPI_RoofSegmentData | Describes various properties/parameters of a roof segment that can be separately adjusted. This structure is used in API_PivotPolyEdgeData |
CAPI_RoofType | Represents a roof element |
CAPI_RoomImage | Structure for retrieving data related to a room |
CAPI_RoomReductionPolyType | Parameters to get room reduction data |
CAPI_RoomRelation | Structure for retrieving data related to a room |
CAPI_RubberArcType | Rubber line definition |
CAPI_RubberLineInfo | Parameters of the rubber line callback function |
CAPI_RubberLineType | Rubber line definition |
CAPI_RubberPolyCallbacks | Parameters of the polygon input operation |
CAPI_RuledShellData | This structure holds the Ruled Shell specific data of API_ShellType |
CAPI_RunType | Describes a continous monostyle piece - called run - of a paragraph |
CAPI_RVMChange | Represents a revision change |
CAPI_RVMDocumentRevision | Represents a Document Revision |
CAPI_RVMIssue | Represents an Issue |
CAPI_RVMLayoutInfo | Represents layout meta data in API_RVMDocumentRevision |
CAPI_SafetyPrefs | The representation of the Preferences / Miscellaneous tab page |
CAPI_SavePars_Archive | Parameters to save the current project as archive file |
CAPI_SavePars_Ifc | Parameters to save the current project as an Ifc file |
CAPI_SavePars_Object | Contains the different options for saving an Archicad object, lamp, door, or window |
CAPI_SavePars_Pdf | Contains the different page options for saving to pdf file |
CAPI_SavePars_Picture | Contains the different options for saving pictures from Archicad |
CAPI_SavePars_PlanDump | Contains the different options for saving a plan dump from Archicad |
CAPI_SavePars_Saf | Contains the export filter type for the SAF file |
CAPI_SectElemType | Describes an element in the section window |
CAPI_SectionSegment | Represents one segment of a section/elevation/interior elevation |
CAPI_Sector | Describes the geometry of a 2D line |
CAPI_SelectionInfo | Information about the current selection |
CAPI_ServerApplicationInfo | Describes the current server application the add-on is running under |
CAPI_SFill_Arc | Describes an arc item in a symbol fill |
CAPI_SFill_Line | Describes a line item in a symbol fill |
CAPI_ShapePrimsParams | Shape primitive parameters |
CAPI_SharingInfo | Project sharing parameters |
CAPI_ShellBaseType | The common parameters of roof (API_RoofType) and shell (API_ShellType) elements |
CAPI_ShellContourData | Shell contour or shell hole contour definition. This structure is used in API_ElementMemo |
CAPI_ShellQuantity | Returns the shell quantity values |
CAPI_ShellShapeData | Contains the profile data of the Shell element. This structure is used in API_ElementMemo |
CAPI_ShellType | Represents a shell element |
CAPI_SideStairStructData | Represents the data of a side supported Stair Structure element |
CAPI_SingleEnumerationVariant | A container for storing a single value from a list of allowed values |
CAPI_SingleVariant | A container for storing a single value |
CAPI_SkeletonOptions | Skeleton drawing options |
CAPI_SkylightQuantity | Describes the different calculated values for skylight |
CAPI_SkylightType | Represents a skylight element |
CAPI_SlabQuantity | Describes the different calculated values for slabs |
CAPI_SlabType | Represents a slab element |
CAPI_SplineDir | Describes the control handles for Bezier-splines |
CAPI_SplineType | Represents a cubic or Bezier-spline |
CAPI_StairBoundaryData | Represents a Stair boundary |
CAPI_StairBoundaryEdgeData | Stores data of a stair boundary edge |
CAPI_StairBoundaryVertexData | Stores data of a stair boundary vertex |
CAPI_StairHeadroomData | Description of the Stair Headroom |
CAPI_StairLayoutData | Represents the layout of a Stair element |
CAPI_StairModelViewOptions | Represents the model view options of Stairs made with Stair Tool. The entire structure is Archicad only |
CAPI_StairMonolithStructureSymbolData | Represents the data of a monolith Stair's Structure elements |
CAPI_StairPolylineData | Represents a Stair polyline (baseline or walking line) |
CAPI_StairPolylineEdgeData | Stores data of a stair polyline edge |
CAPI_StairPolylineVertexData | Stores data of a stair polyline vertex |
CAPI_StairQuantity | Calculates values for stairs |
CAPI_StairRiserQuantity | Calculated values for the stair riser |
CAPI_StairRiserType | Represents a Riser element |
CAPI_StairRulesData | Represents a the Rules and Standards of a Stair element |
CAPI_StairStructureComponentSettingsVisibility | Settings for visibility of the stair component strucutre |
CAPI_StairStructureComponentSettingsVisibilityOnStory | Describes story's stair structure component visibility settings |
CAPI_StairStructureDrainingData | Represents the draining of a monolithic Stair Structure element |
CAPI_StairStructureQuantity | Calculated values for the stair structure |
CAPI_StairStructureSymbolData | Represents the data of a 2D symbol a Stair's Structure elements |
CAPI_StairStructureType | Represents a Stair Structure element |
CAPI_StairTreadQuantity | Calculated values for a stair tread |
CAPI_StairTreadType | Represents a Tread element |
CAPI_StairType | Represents a Stair element |
CAPI_StoryCmdType | Parameters of the change story settings command |
CAPI_StoryInfo | Story information of the active project |
CAPI_StoryType | Parameters of one story |
CAPI_StoryVisibility | Determines the appearance of model elements on different stories |
CAPI_SubElement | Helper structure to create / modify / get markers for window, door, section, elevation, interior elevation, detail, worksheet elements and curtain wall parts |
CAPI_SubSet | Represents a Subset in the Layout Book |
CAPI_SunAngleSettings | Sun angle settings |
CAPI_SunInfo | Parameters of the sunlight |
CAPI_SurfaceLoadCustomData | Describes Custom Surface Coordinates for Surface Load |
CAPI_SymbolHatchDef | Describes the details of a symbol fill |
CAPI_SyTran | Symbol transformation parameters |
CAPI_TabType | Describes a tabulator of a paragraph |
CAPI_TestSplineFit | Contains parameters to calculate the maximal distance of a spline segment and a set of coordinates |
CAPI_TexCoordPars | Identifies the surface point to get the texture coordinates for |
CAPI_TextFrameType | Parameters of the Text frame shape |
CAPI_TextLinePars | Represents some text to measure its length |
CAPI_TextType | Represents a text, or a textual label |
CAPI_Texture | Texture reference |
CAPI_ToolBoxInfo | Contains information on the current state of the toolbox |
CAPI_ToolBoxItem | Data of the active toolbox mode |
CAPI_Tranmat | A 3*4 transformation matrix |
CAPI_TranslatorNameConfig | Represents a translator by its GUID and its name |
CAPI_UCCallbackType | Describes the attribute set to be used in a user control dialog item |
CAPI_UIStructureDisplay | This structure represents the Partial Structure Display state |
CAPI_UmatType | Representation of a 3D material |
CAPI_UniformAttributeOptions | General representation of a Model Display in 3D Document |
CAPI_UnitConversionData | Input and output struct for ACAPI_Conversion_GetConvertedUnitValue |
CAPI_UnitType | Description of an unit |
CAPI_UserData | Custom data record attached to element sets |
CAPI_UserInfo | Information on a registered Team Member |
CAPI_UVCoord | The local coordinate system of a texture at a given surface point |
CAPI_Variant | A container that can store different types of data |
CAPI_VectType | Representation of a 3D normal vector |
CAPI_VerticalLink | Option for anchoring the vertical position of an opening within the wall or the roof |
CAPI_VertType | Representation of a 3D vertex |
CAPI_ViewOptions | Describes various display output options |
CAPI_VisualOverriddenImage | Visual overridden image descriptor |
CAPI_VLNumType | The possible values for a numeric parameter |
CAPI_WallPart | Section of a wall segment that neighbours a border line of the room |
CAPI_WallQuantity | Describes the different calculated values for walls |
CAPI_WallRelation | Structure for retrieving connection data of a wall |
CAPI_WallType | Represents a wall element |
CAPI_WindowInfo | Identification parameters of a project window |
CAPI_WindowQuantity | Describes the different calculated values for windows |
CAPI_WindowType | Represents a window element |
CAPI_WindowValidatorInfo | Holds information on elements and custom checksums that should be validated for the window |
CAPI_WorkingUnitPrefs | The representation of the Preferences / Units tab page |
CAPI_Wrapping | Texture wrapping parameters. This structure is used in API_LocalCoordsType |
CAPI_ZoneAllQuantity | Describes the different calculated values for zones |
CAPI_ZoneCatType | Zone category attribute representation |
CAPI_ZonePrefs | The representation of the Preferences / Zones tab page |
CAPI_ZoneType | Represents a zone stamp |
CAPIOptional | Represents an optional in the API layer |
CAPIVariant | Represents a variant in the API layer |
CINavigatorCallbackInterface | Callback interface object to register with ACAPI_Navigator_RegisterCallbackInterface |
CNullValueType | Represents NullValueType in the API layer |