Archicad 27 C++ API
Loading...
Searching...
No Matches
API_StairBoundaryData Struct Reference

Represents a Stair boundary. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Polygon polygon
 The API polygon element describing the amounts of vertices in the boundary line.
 
API_Coord ** coords
 The coordinates of the vertices of the boundary line.
 
Int32 ** pends
 The polygon endings of the boundary line.
 
API_PolyArc ** parcs
 The arcs of the boundary line.
 
API_StairBoundaryEdgeDataedgeData
 The edge data of each edge.
 
API_StairBoundaryVertexDatavertexData
 The vertex data of each vertex.
 
bool isCustom
 True, if the stair boundary is customized.
 

Detailed Description

Represents a Stair boundary.

Remarks
There are two Stair boundaries in the API_ElementMemo structure, the one with the index of 0 describes the left, and the one with the index of 1 describes the right side boundary line of the Stair element.